Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "PIP is a tool for installing and managing Python packages" |
| 2 | HOMEPAGE = "https://pip.pypa.io/" |
| 3 | LICENSE = "MIT & LGPL-2.1" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e" |
| 5 | |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame^] | 6 | SRC_URI[md5sum] = "1aaaf90fbafc50e7ba1e66ffceb00960" |
| 7 | SRC_URI[sha256sum] = "21207d76c1031e517668898a6b46a9fb1501c7a4710ef5dfd6a40ad9e6757ea7" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 8 | |
| 9 | inherit pypi setuptools |
| 10 | |
| 11 | # Since PIP is like CPAN for PERL we need to drag in all python modules to ensure everything works |
| 12 | RDEPENDS_${PN}_class-target = "python-modules python-distribute python-misc" |
| 13 | |
| 14 | BBCLASSEXTEND = "native nativesdk" |