blob: a778d2609759995381460915a18b0b02ac0f9555 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "High Availability monitor built upon LVS, VRRP and service pollers"
2DESCRIPTION = "Keepalived is a routing software written in C. The main goal \
3of this project is to provide simple and robust facilities for loadbalancing \
4and high-availability to Linux system and Linux based infrastructures. \
5Loadbalancing framework relies on well-known and widely used Linux Virtual \
6Server (IPVS) kernel module providing Layer4 loadbalancing \
7"
8HOMEPAGE = "http://www.keepalived.org/"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
13SRC_URI = "http://www.keepalived.org/software/${BP}.tar.gz"
Andrew Geisslerac970dd2021-02-12 15:32:45 -060014SRC_URI[sha256sum] = "91186f20c83ffc48d7a15a9a6e2329ed4feeb2dcb51f4aa9672c8840190ea741"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050015UPSTREAM_CHECK_URI = "https://github.com/acassen/keepalived/releases"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17DEPENDS = "libnfnetlink openssl"
18
19inherit autotools pkgconfig systemd
20
21PACKAGECONFIG ??= "libnl snmp \
22 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
23"
24PACKAGECONFIG[libnl] = "--enable-libnl,--disable-libnl,libnl"
25PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp"
26PACKAGECONFIG[systemd] = "--with-init=systemd --with-systemdsystemunitdir=${systemd_system_unitdir},--with-init=SYSV,systemd"
27
Andrew Geissler82c905d2020-04-13 13:39:40 -050028EXTRA_OEMAKE = "initdir=${sysconfdir}/init.d"
29
30do_install_append() {
31 if [ -f ${D}${sysconfdir}/init.d/${BPN} ]; then
32 chmod 0755 ${D}${sysconfdir}/init.d/${BPN}
33 sed -i 's#rc.d/##' ${D}${sysconfdir}/init.d/${BPN}
34 fi
35
36 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
37 install -D -m 0644 ${B}/${BPN}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
38 fi
39}
40
41FILES_${PN} += "${datadir}/snmp/mibs/KEEPALIVED-MIB.txt"
42
43SYSTEMD_SERVICE_${PN} = "keepalived.service"
44SYSTEMD_AUTO_ENABLE ?= "disable"