Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Commented config.txt file for the Raspberry Pi. \ |
| 2 | The Raspberry Pi config.txt file is read by the GPU before \ |
| 3 | the ARM core is initialised. It can be used to set various \ |
| 4 | system configuration parameters." |
| 5 | LICENSE = "MIT" |
Brad Bishop | f27bdd5 | 2018-05-07 15:42:31 +0200 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 7 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 8 | COMPATIBLE_MACHINE = "^rpi$" |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 9 | |
| 10 | SRCREV = "648ffc470824c43eb0d16c485f4c24816b32cd6f" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | SRC_URI = "git://github.com/Evilpaul/RPi-config.git;protocol=https;branch=master \ |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 12 | " |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 16 | PR = "r5" |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 17 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 18 | INHIBIT_DEFAULT_DEPS = "1" |
| 19 | |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 20 | PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}" |
| 21 | PITFT22="${@bb.utils.contains("MACHINE_FEATURES", "pitft22", "1", "0", d)}" |
| 22 | PITFT28r="${@bb.utils.contains("MACHINE_FEATURES", "pitft28r", "1", "0", d)}" |
Brad Bishop | 1b9ee29 | 2020-01-16 09:06:00 -0500 | [diff] [blame] | 23 | PITFT28c="${@bb.utils.contains("MACHINE_FEATURES", "pitft28c", "1", "0", d)}" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 24 | PITFT35r="${@bb.utils.contains("MACHINE_FEATURES", "pitft35r", "1", "0", d)}" |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 25 | |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 26 | VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 27 | VC4DTBO ?= "vc4-kms-v3d" |
Andrew Geissler | 4fc9e43 | 2020-06-27 00:13:56 -0500 | [diff] [blame] | 28 | GPIO_IR ?= "18" |
| 29 | GPIO_IR_TX ?= "17" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 30 | |
Andrew Geissler | 9d7e0aa | 2020-08-21 15:56:44 -0500 | [diff] [blame] | 31 | CAN_OSCILLATOR ?= "16000000" |
| 32 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 33 | ENABLE_UART ??= "" |
| 34 | |
Andrew Geissler | a4353c8 | 2021-06-25 14:23:27 -0500 | [diff] [blame] | 35 | WM8960="${@bb.utils.contains("MACHINE_FEATURES", "wm8960", "1", "0", d)}" |
| 36 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 37 | inherit deploy nopackages |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 38 | |
| 39 | do_deploy() { |
Andrew Geissler | 9d7e0aa | 2020-08-21 15:56:44 -0500 | [diff] [blame] | 40 | install -d ${DEPLOYDIR}/${BOOTFILES_DIR_NAME} |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 41 | CONFIG=${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 42 | |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 43 | cp ${S}/config.txt $CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 44 | |
| 45 | if [ -n "${KEY_DECODE_MPG2}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 46 | sed -i '/#decode_MPG2=/ c\decode_MPG2=${KEY_DECODE_MPG2}' $CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 47 | fi |
| 48 | if [ -n "${KEY_DECODE_WVC1}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 49 | sed -i '/#decode_WVC1=/ c\decode_WVC1=${KEY_DECODE_WVC1}' $CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 50 | fi |
| 51 | if [ -n "${DISABLE_OVERSCAN}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 52 | sed -i '/#disable_overscan=/ c\disable_overscan=${DISABLE_OVERSCAN}' $CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 53 | fi |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 54 | if [ "${DISABLE_SPLASH}" = "1" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 55 | sed -i '/#disable_splash=/ c\disable_splash=${DISABLE_SPLASH}' $CONFIG |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 56 | fi |
| 57 | |
| 58 | # Set overclocking options |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 59 | if [ -n "${ARM_FREQ}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 60 | sed -i '/#arm_freq=/ c\arm_freq=${ARM_FREQ}' $CONFIG |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 61 | fi |
| 62 | if [ -n "${GPU_FREQ}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 63 | sed -i '/#gpu_freq=/ c\gpu_freq=${GPU_FREQ}' $CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 64 | fi |
| 65 | if [ -n "${CORE_FREQ}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 66 | sed -i '/#core_freq=/ c\core_freq=${CORE_FREQ}' $CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 67 | fi |
| 68 | if [ -n "${SDRAM_FREQ}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 69 | sed -i '/#sdram_freq=/ c\sdram_freq=${SDRAM_FREQ}' $CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 70 | fi |
| 71 | if [ -n "${OVER_VOLTAGE}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 72 | sed -i '/#over_voltage=/ c\over_voltage=${OVER_VOLTAGE}' $CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 73 | fi |
| 74 | |
| 75 | # GPU memory |
| 76 | if [ -n "${GPU_MEM}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 77 | sed -i '/#gpu_mem=/ c\gpu_mem=${GPU_MEM}' $CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 78 | fi |
| 79 | if [ -n "${GPU_MEM_256}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 80 | sed -i '/#gpu_mem_256=/ c\gpu_mem_256=${GPU_MEM_256}' $CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 81 | fi |
| 82 | if [ -n "${GPU_MEM_512}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 83 | sed -i '/#gpu_mem_512=/ c\gpu_mem_512=${GPU_MEM_512}' $CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 84 | fi |
| 85 | if [ -n "${GPU_MEM_1024}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 86 | sed -i '/#gpu_mem_1024=/ c\gpu_mem_1024=${GPU_MEM_1024}' $CONFIG |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 87 | fi |
| 88 | |
| 89 | # Set boot delay |
| 90 | if [ -n "${BOOT_DELAY}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 91 | sed -i '/#boot_delay=/ c\boot_delay=${BOOT_DELAY}' $CONFIG |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 92 | fi |
| 93 | if [ -n "${BOOT_DELAY_MS}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 94 | sed -i '/#boot_delay_ms=/ c\boot_delay_ms=${BOOT_DELAY_MS}' $CONFIG |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 95 | fi |
| 96 | |
| 97 | # Set HDMI and composite video options |
| 98 | if [ -n "${HDMI_FORCE_HOTPLUG}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 99 | sed -i '/#hdmi_force_hotplug=/ c\hdmi_force_hotplug=${HDMI_FORCE_HOTPLUG}' $CONFIG |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 100 | fi |
| 101 | if [ -n "${HDMI_DRIVE}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 102 | sed -i '/#hdmi_drive=/ c\hdmi_drive=${HDMI_DRIVE}' $CONFIG |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 103 | fi |
| 104 | if [ -n "${HDMI_GROUP}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 105 | sed -i '/#hdmi_group=/ c\hdmi_group=${HDMI_GROUP}' $CONFIG |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 106 | fi |
| 107 | if [ -n "${HDMI_MODE}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 108 | sed -i '/#hdmi_mode=/ c\hdmi_mode=${HDMI_MODE}' $CONFIG |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 109 | fi |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 110 | if [ -n "${HDMI_CVT}" ]; then |
| 111 | echo 'hdmi_cvt=${HDMI_CVT}' >> $CONFIG |
| 112 | fi |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 113 | if [ -n "${CONFIG_HDMI_BOOST}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 114 | sed -i '/#config_hdmi_boost=/ c\config_hdmi_boost=${CONFIG_HDMI_BOOST}' $CONFIG |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 115 | fi |
| 116 | if [ -n "${SDTV_MODE}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 117 | sed -i '/#sdtv_mode=/ c\sdtv_mode=${SDTV_MODE}' $CONFIG |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 118 | fi |
| 119 | if [ -n "${SDTV_ASPECT}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 120 | sed -i '/#sdtv_aspect=/ c\sdtv_aspect=${SDTV_ASPECT}' $CONFIG |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 121 | fi |
| 122 | if [ -n "${DISPLAY_ROTATE}" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 123 | sed -i '/#display_rotate=/ c\display_rotate=${DISPLAY_ROTATE}' $CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 124 | fi |
| 125 | |
| 126 | # Video camera support |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 127 | if [ "${VIDEO_CAMERA}" = "1" ]; then |
William A. Kennington III | a99e9b6 | 2021-06-02 12:47:56 -0700 | [diff] [blame] | 128 | # It has been observed that Raspberry Pi 4B 4GB may fail to enable the |
| 129 | # camera if "start_x=1" is at the end of the file. Therefore, |
| 130 | # "start_x=1" has been set to replace the original occurrence in |
| 131 | # config.txt, which is at the middle of the file. |
| 132 | # The exact underlying cause is unknown. There are similar issues |
| 133 | # reported in the raspberrypi/firware repo and the conclusion reached |
| 134 | # was that there could be a file size limitation affecting certain |
| 135 | # variables. It was commented that this limitation could be 4k but |
| 136 | # not proved. |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 137 | sed -i '/#start_x=/ c\start_x=1' $CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 138 | fi |
| 139 | |
| 140 | # Offline compositing support |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 141 | if [ "${DISPMANX_OFFLINE}" = "1" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 142 | echo "# Enable offline compositing" >>$CONFIG |
| 143 | echo "dispmanx_offline=1" >>$CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 144 | fi |
| 145 | |
| 146 | # SPI bus support |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 147 | if [ "${ENABLE_SPI_BUS}" = "1" ] || [ "${PITFT}" = "1" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 148 | echo "# Enable SPI bus" >>$CONFIG |
| 149 | echo "dtparam=spi=on" >>$CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 150 | fi |
| 151 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 152 | # I2C support |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 153 | if [ "${ENABLE_I2C}" = "1" ] || [ "${PITFT}" = "1" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 154 | echo "# Enable I2C" >>$CONFIG |
| 155 | echo "dtparam=i2c1=on" >>$CONFIG |
| 156 | echo "dtparam=i2c_arm=on" >>$CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 157 | fi |
| 158 | |
| 159 | # PiTFT22 display support |
| 160 | if [ "${PITFT22}" = "1" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 161 | echo "# Enable PITFT22 display" >>$CONFIG |
| 162 | echo "dtoverlay=pitft22,rotate=270,speed=32000000,txbuflen=32768" >>$CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 163 | fi |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 164 | if [ "${PITFT28r}" = "1" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 165 | echo "# Enable PITFT28r display" >>$CONFIG |
| 166 | echo "dtoverlay=pitft28-resistive,rotate=90,speed=32000000,txbuflen=32768" >>$CONFIG |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 167 | fi |
Brad Bishop | 1b9ee29 | 2020-01-16 09:06:00 -0500 | [diff] [blame] | 168 | if [ "${PITFT28c}" = "1" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 169 | echo "# Enable PITFT28c display" >>$CONFIG |
| 170 | echo "dtoverlay=pitft28-capacitive,rotate=90,speed=32000000,txbuflen=32768" >>$CONFIG |
| 171 | echo "dtoverlay=pitft28-capacitive,touch-swapxy,touch-invx" >>$CONFIG |
Brad Bishop | 1b9ee29 | 2020-01-16 09:06:00 -0500 | [diff] [blame] | 172 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 173 | if [ "${PITFT35r}" = "1" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 174 | echo "# Enable PITFT35r display" >>$CONFIG |
| 175 | echo "dtoverlay=pitft35-resistive,rotate=90,speed=42000000,fps=20" >>$CONFIG |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 176 | fi |
| 177 | |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 178 | # UART support |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 179 | if [ "${ENABLE_UART}" = "1" ] || [ "${ENABLE_UART}" = "0" ] ; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 180 | echo "# Enable UART" >>$CONFIG |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 181 | echo "enable_uart=${ENABLE_UART}" >>$CONFIG |
| 182 | elif [ -n "${ENABLE_UART}" ]; then |
| 183 | bbfatal "Invalid value for ENABLE_UART [${ENABLE_UART}]. The value for ENABLE_UART can be 0 or 1." |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 184 | fi |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 185 | |
Andrew Geissler | 4fc9e43 | 2020-06-27 00:13:56 -0500 | [diff] [blame] | 186 | # Infrared support |
| 187 | if [ "${ENABLE_IR}" = "1" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 188 | echo "# Enable infrared" >>$CONFIG |
| 189 | echo "dtoverlay=gpio-ir,gpio_pin=${GPIO_IR}" >>$CONFIG |
| 190 | echo "dtoverlay=gpio-ir-tx,gpio_pin=${GPIO_IR_TX}" >>$CONFIG |
Andrew Geissler | 4fc9e43 | 2020-06-27 00:13:56 -0500 | [diff] [blame] | 191 | fi |
| 192 | |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 193 | # VC4 Graphics support |
| 194 | if [ "${VC4GRAPHICS}" = "1" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 195 | echo "# Enable VC4 Graphics" >> $CONFIG |
| 196 | echo "dtoverlay=${VC4DTBO}" >> $CONFIG |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 197 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 198 | |
Andrew Geissler | 26e4bea | 2020-11-30 19:54:03 -0600 | [diff] [blame] | 199 | # Choose Camera Sensor to be used, default imx219 sensor |
| 200 | if [ "${RASPBERRYPI_CAMERA_V2}" = "1" ]; then |
William A. Kennington III | a99e9b6 | 2021-06-02 12:47:56 -0700 | [diff] [blame] | 201 | echo "# Enable Sony RaspberryPi Camera(imx219)" >> $CONFIG |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 202 | echo "dtoverlay=imx219" >> $CONFIG |
Andrew Geissler | 26e4bea | 2020-11-30 19:54:03 -0600 | [diff] [blame] | 203 | fi |
| 204 | |
William A. Kennington III | a99e9b6 | 2021-06-02 12:47:56 -0700 | [diff] [blame] | 205 | # Choose Camera Sensor to be used, default imx477 sensor |
| 206 | #if [ "${RASPBERRYPI_HD_CAMERA}" = "1" ]; then |
| 207 | # echo "# Enable Sony RaspberryPi Camera(imx477)" >> $CONFIG |
| 208 | # echo "dtoverlay=imx477" >> $CONFIG |
| 209 | #fi |
| 210 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 211 | # Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm) |
| 212 | if [ "${WAVESHARE_1024X600_C_2_1}" = "1" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 213 | echo "# Waveshare \"C\" 1024x600 7\" Rev2.1 IPS capacitive touch screen" >> $CONFIG |
| 214 | echo "max_usb_current=1" >> $CONFIG |
| 215 | echo "hdmi_group=2" >> $CONFIG |
| 216 | echo "hdmi_mode=87" >> $CONFIG |
| 217 | echo "hdmi_cvt 1024 600 60 6 0 0 0" >> $CONFIG |
| 218 | echo "hdmi_drive=1" >> $CONFIG |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 219 | fi |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 220 | |
| 221 | # DWC2 USB peripheral support |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 222 | if ([ "${ENABLE_DWC2_PERIPHERAL}" = "1" ] && [ "${ENABLE_DWC2_OTG}" != "1" ]); then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 223 | echo "# Enable USB peripheral mode" >> $CONFIG |
| 224 | echo "dtoverlay=dwc2,dr_mode=peripheral" >> $CONFIG |
| 225 | fi |
| 226 | |
| 227 | # DWC2 USB host mode support |
| 228 | if [ "${ENABLE_DWC2_HOST}" = "1" ]; then |
| 229 | echo "# Enable USB host mode" >> $CONFIG |
| 230 | echo "dtoverlay=dwc2,dr_mode=host" >> $CONFIG |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 231 | fi |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 232 | |
| 233 | # DWC2 USB OTG support |
| 234 | if ([ "${ENABLE_DWC2_OTG}" = "1" ] && [ "${ENABLE_DWC2_PERIPHERAL}" != "1" ]); then |
| 235 | echo "# Enable USB OTG mode" >> $CONFIG |
| 236 | echo "dtoverlay=dwc2,dr_mode=otg" >> $CONFIG |
| 237 | fi |
Brad Bishop | f27bdd5 | 2018-05-07 15:42:31 +0200 | [diff] [blame] | 238 | |
| 239 | # AT86RF23X support |
| 240 | if [ "${ENABLE_AT86RF}" = "1" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 241 | echo "# Enable AT86RF23X" >>$CONFIG |
| 242 | echo "dtoverlay=at86rf233,speed=3000000" >>$CONFIG |
Brad Bishop | f27bdd5 | 2018-05-07 15:42:31 +0200 | [diff] [blame] | 243 | fi |
| 244 | |
Andrew Geissler | 5d59ec7 | 2020-07-24 16:09:26 -0500 | [diff] [blame] | 245 | # ENABLE DUAL CAN |
| 246 | if [ "${ENABLE_DUAL_CAN}" = "1" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 247 | echo "# Enable DUAL CAN" >>$CONFIG |
| 248 | echo "dtoverlay=mcp2515-can0,oscillator=${CAN_OSCILLATOR},interrupt=25" >>$CONFIG |
| 249 | echo "dtoverlay=mcp2515-can1,oscillator=${CAN_OSCILLATOR},interrupt=24" >>$CONFIG |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 250 | # ENABLE CAN |
Andrew Geissler | 5d59ec7 | 2020-07-24 16:09:26 -0500 | [diff] [blame] | 251 | elif [ "${ENABLE_CAN}" = "1" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 252 | echo "# Enable CAN" >>$CONFIG |
| 253 | echo "dtoverlay=mcp2515-can0,oscillator=${CAN_OSCILLATOR},interrupt=25" >>$CONFIG |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 254 | fi |
| 255 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 256 | # Append extra config if the user has provided any |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 257 | printf "${RPI_EXTRA_CONFIG}\n" >> $CONFIG |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 258 | |
| 259 | # Handle setup with armstub file |
| 260 | if [ "${@bb.utils.contains("MACHINE_FEATURES", "armstub", "1", "0", d)}" = "1" ]; then |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 261 | echo "\n# ARM stub configuration" >> $CONFIG |
| 262 | echo "armstub=${ARMSTUB}" >> $CONFIG |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 263 | case "${ARMSTUB}" in |
| 264 | *-gic.bin) |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 265 | echo "enable_gic=1" >> $CONFIG |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 266 | ;; |
| 267 | esac |
| 268 | fi |
Andrew Geissler | a4353c8 | 2021-06-25 14:23:27 -0500 | [diff] [blame] | 269 | |
| 270 | # WM8960 support |
| 271 | if [ "${WM8960}" = "1" ]; then |
| 272 | echo "# Enable WM8960" >> $CONFIG |
| 273 | echo "dtoverlay=wm8960-soundcard" >> $CONFIG |
| 274 | fi |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 275 | } |
| 276 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 277 | do_deploy:append:raspberrypi3-64() { |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 278 | echo "# have a properly sized image" >> $CONFIG |
| 279 | echo "disable_overscan=1" >> $CONFIG |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 280 | |
Andrew Geissler | 1110521 | 2021-02-12 15:30:38 -0600 | [diff] [blame] | 281 | echo "# Enable audio (loads snd_bcm2835)" >> $CONFIG |
| 282 | echo "dtparam=audio=on" >> $CONFIG |
Brad Bishop | 3a5fbf5 | 2017-12-04 02:17:07 -0500 | [diff] [blame] | 283 | } |
| 284 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 285 | do_deploy:append() { |
| 286 | if grep -q -E '^.{80}.$' ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/config.txt; then |
| 287 | bbwarn "config.txt contains lines longer than 80 characters, this is not supported" |
| 288 | fi |
| 289 | } |
| 290 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 291 | addtask deploy before do_build after do_install |
Andrew Geissler | 9d7e0aa | 2020-08-21 15:56:44 -0500 | [diff] [blame] | 292 | do_deploy[dirs] += "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}" |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 293 | |
| 294 | PACKAGE_ARCH = "${MACHINE_ARCH}" |