Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \ |
| 2 | server for multi-processor machines. It is a new implementation of the \ |
| 3 | JACK server core features that aims in removing some limitations of \ |
| 4 | the JACK1 design. The activation system has been changed for a data \ |
| 5 | flow model and lock-free programming techniques for graph access have \ |
| 6 | been used to have a more dynamic and robust system." |
| 7 | SECTION = "libs/multimedia" |
| 8 | |
| 9 | LICENSE = "GPLv2 & LGPLv2.1" |
| 10 | LIC_FILES_CHKSUM = " \ |
| 11 | file://common/jack/control.h;beginline=2;endline=21;md5=e6df0bf30cde8b3b825451459488195d \ |
| 12 | file://common/jack/jack.h;beginline=1;endline=19;md5=6b736ed6b810592b135480a5e853392e \ |
| 13 | " |
| 14 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 15 | DEPENDS = "libsamplerate0 libsndfile1 readline" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 16 | |
Brad Bishop | 0e2770c | 2020-01-21 07:31:46 -0500 | [diff] [blame] | 17 | SRC_URI = "git://github.com/jackaudio/jack2.git \ |
| 18 | file://0001-example-clients-Use-c-compiler-for-jack_simdtests.patch \ |
| 19 | " |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 20 | SRCREV = "b54a09bf7ef760d81fdb8544ad10e45575394624" |
| 21 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | inherit waf pkgconfig |
| 25 | |
| 26 | PACKAGECONFIG ??= "alsa" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 27 | PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | # --dbus only stops building jackd -> add --classic |
| 29 | PACKAGECONFIG[dbus] = "--dbus --classic,,dbus" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 30 | PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 31 | |
| 32 | # portaudio is for windows builds only |
| 33 | EXTRA_OECONF = "--portaudio=no" |
| 34 | |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 35 | do_install_append() { |
| 36 | if ! ${@bb.utils.contains('PACKAGECONFIG', 'dbus', True, False, d)}; then |
| 37 | rm -f ${D}${bindir}/jack_control |
| 38 | fi |
| 39 | } |
| 40 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 41 | PACKAGES =+ "libjack jack-server jack-utils" |
| 42 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 43 | RDEPENDS_jack-dev_remove = "${PN} (= ${EXTENDPKGV})" |
| 44 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 45 | FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 46 | FILES_jack-server = " \ |
| 47 | ${datadir}/dbus-1/services \ |
| 48 | ${bindir}/jackdbus \ |
| 49 | ${bindir}/jackd \ |
| 50 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 51 | FILES_jack-utils = "${bindir}/*" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 52 | |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 53 | FILES_${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/*" |