Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 1 | SUMMARY = "The extensible, standards compliant build backend used by Hatch" |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://hatch.pypa.io/" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cbe2fd33fc9297692812fc94b7d27fd9" |
| 5 | |
| 6 | inherit pypi python_hatchling |
| 7 | |
| 8 | DEPENDS += "python3-pluggy-native python3-tomli-native python3-pathspec-native python3-packaging-native python3-editables-native" |
| 9 | DEPENDS:remove:class-native = "python3-hatchling-native" |
| 10 | |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "bd6e8505de511ac4217ff50927f6d1845494608e401e63a62b830c31fb613544" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 12 | |
| 13 | do_compile:prepend() { |
| 14 | export PYTHONPATH=src |
| 15 | } |
| 16 | |
| 17 | BBCLASSEXTEND = "native nativesdk" |