Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "library to access web services that claim to be "RESTful"" |
Andrew Geissler | eafcbb8 | 2020-06-05 17:59:17 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://wiki.gnome.org/Projects/Librest" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 3 | LICENSE = "LGPL-2.1-only" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1" |
| 5 | |
| 6 | GNOMEBASEBUILDCLASS = "autotools" |
| 7 | |
| 8 | DEPENDS = " \ |
| 9 | libxml2-native \ |
| 10 | glib-2.0-native \ |
| 11 | glib-2.0 \ |
| 12 | libsoup-2.4 \ |
| 13 | " |
| 14 | |
| 15 | inherit gnomebase gobject-introspection gtk-doc vala |
| 16 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 17 | PV .= "+git${SRCPV}" |
| 18 | SRCREV = "7b46065dea860ef09861f4d70124728b8270c8b7" |
| 19 | SRC_URI = "git://gitlab.gnome.org/GNOME/librest;protocol=https;branch=master \ |
| 20 | file://0001-Use-GUri-instead-of-SoupURI.patch \ |
| 21 | file://0002-Port-to-libsoup3.patch \ |
| 22 | " |
| 23 | S = "${WORKDIR}/git" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | do_configure:prepend() { |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 26 | # rest expects introspection.m4 at custom location (see aclocal.m4). |
| 27 | cp -f ${STAGING_DIR_TARGET}/${datadir}/aclocal/introspection.m4 ${S}/build |
| 28 | } |
| 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | do_compile:prepend() { |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 31 | export GIR_EXTRA_LIBS_PATH="${B}/rest/.libs" |
| 32 | } |
| 33 | |