Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Linux Test Project" |
| 2 | DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features." |
| 3 | HOMEPAGE = "https://linux-test-project.github.io/" |
| 4 | SECTION = "console/utils" |
| 5 | LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later & BSD-2-Clause" |
| 6 | LIC_FILES_CHKSUM = "\ |
| 7 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 8 | file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \ |
| 9 | file://testcases/network/can/filter-tests/COPYING;md5=5b155ea7d7f86eae8e8832955d8b70bc \ |
| 10 | " |
| 11 | |
| 12 | DEPENDS = "attr libaio libcap acl openssl zip-native" |
| 13 | DEPENDS:append:libc-musl = " fts " |
| 14 | EXTRA_OEMAKE:append:libc-musl = " LIBC=musl " |
| 15 | EXTRA_OECONF:append:libc-musl = " LIBS=-lfts " |
| 16 | |
| 17 | # since ltp contains x86-64 assembler which uses the frame-pointer register, |
| 18 | # set -fomit-frame-pointer x86-64 to handle cases where optimisation |
| 19 | # is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer |
| 20 | # earlier in CFLAGS, etc. |
| 21 | CFLAGS:append:x86-64 = " -fomit-frame-pointer" |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 22 | TUNE_CCARGS:remove:x86 = "-mfpmath=sse" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 23 | TUNE_CCARGS:remove:x86-64 = "-mfpmath=sse" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 24 | |
| 25 | CFLAGS:append:powerpc64 = " -D__SANE_USERSPACE_TYPES__" |
| 26 | CFLAGS:append:mipsarchn64 = " -D__SANE_USERSPACE_TYPES__" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 27 | SRCREV = "6f88e0f6f1d6eb12c48c902f50f47ecbd3b0f18a" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 28 | |
| 29 | SRC_URI = "git://github.com/linux-test-project/ltp.git;branch=master;protocol=https \ |
| 30 | file://0001-Remove-OOM-tests-from-runtest-mm.patch \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 31 | file://disable_hanging_tests.patch \ |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 32 | file://0001-kvm-Fix-stack-access-mode-in-KVM-test-ELF-headers.patch \ |
| 33 | file://0002-kvm-use-LD-instead-of-hardcoding-ld.patch \ |
| 34 | file://0003-Add-KVM_LD-Makefile-variable-for-building-KVM-payloa.patch \ |
| 35 | file://0001-nfs05_make_tree-Restore-5-min-timeout.patch \ |
| 36 | file://0001-syscalls-migrate_pages03-restore-runtime-to-5m.patch \ |
| 37 | file://0001-mountns0-1-3-wait-for-umount-completed-in-thread_b.patch \ |
| 38 | file://0001-netstress-Restore-runtime-to-5m.patch \ |
| 39 | file://0001-net_stress-Fix-usage-of-variables-from-tst_net.sh.patch \ |
| 40 | file://0001-memcg-functional-Fix-usage-of-PAGESIZE-from-memcg_li.patch \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 41 | file://0001-lapi-pidfd-adding-pidfd-header-file.patch \ |
| 42 | file://0001-lapi-fsmount-resolve-conflict-in-different-header-fi.patch \ |
| 43 | file://0001-rt-migrate-Use-int-instead-of-pthread_t-for-thread-I.patch \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 44 | " |
| 45 | |
| 46 | S = "${WORKDIR}/git" |
| 47 | |
| 48 | inherit autotools-brokensep pkgconfig |
| 49 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 50 | # Version 20220527 added KVM test infrastructure which currently fails to build with gold due to |
| 51 | # SORT_NONE in linker script which isn't supported by gold: |
| 52 | # https://sourceware.org/bugzilla/show_bug.cgi?id=18097 |
| 53 | # https://github.com/linux-test-project/ltp/commit/3fce2064b54843218d085aae326c8f7ecf3a8c41#diff-39268f0855c634ca48c8993fcd2c95b12a65b79e8d9fa5ccd6b0f5a8785c0dd6R36 |
| 54 | LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd', '', d)}" |
| 55 | |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 56 | # After 0002-kvm-use-LD-instead-of-hardcoding-ld.patch |
| 57 | # https://github.com/linux-test-project/ltp/commit/f94e0ef3b7280f886384703ef9019aaf2f2dfebb |
| 58 | # it fails with gold also a bit later when trying to use *-payload.bin |
| 59 | # http://errors.yoctoproject.org/Errors/Details/663094/ |
| 60 | # work around this by forcing .bfd linked in LD when ld-is-gold is in DISTRO_FEATURES |
| 61 | KVM_LD = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', '${HOST_PREFIX}ld.bfd${TOOLCHAIN_OPTIONS} ${HOST_LD_ARCH}', '${LD}', d)}" |
| 62 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 63 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 64 | |
| 65 | export prefix = "/opt/${PN}" |
| 66 | export exec_prefix = "/opt/${PN}" |
| 67 | |
| 68 | PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl," |
| 69 | EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4" |
| 70 | EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite " |
| 71 | # ltp network/rpc test cases ftbfs when libtirpc is found |
| 72 | EXTRA_OECONF += " --without-tirpc " |
| 73 | |
| 74 | do_compile() { |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 75 | oe_runmake HOSTCC="${CC_FOR_BUILD}" HOST_CFLAGS="${CFLAGS_FOR_BUILD}" HOST_LDFLAGS="${LDFLAGS_FOR_BUILD}" KVM_LD="${KVM_LD}" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 76 | } |
| 77 | |
| 78 | do_install(){ |
| 79 | install -d ${D}${prefix}/ |
| 80 | oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install include-install |
| 81 | |
| 82 | # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run |
| 83 | # as it lacks dependency on some perl moudle such as LWP::Simple |
| 84 | # And this script previously works as a tool for analyzing failures from LTP |
| 85 | # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses |
| 86 | # http://khack.osdl.org to retrieve ltp test results run on |
| 87 | # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible |
| 88 | rm -rf ${D}${prefix}/bin/STPfailure_report.pl |
| 89 | |
| 90 | # Copy POSIX test suite into ${D}${prefix}/testcases by manual |
| 91 | cp -r testcases/open_posix_testsuite ${D}${prefix}/testcases |
| 92 | |
| 93 | # Makefile were configured in the build system |
| 94 | find ${D}${prefix} -name Makefile | xargs -n 1 sed -i \ |
| 95 | -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \ |
| 96 | -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \ |
| 97 | -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \ |
| 98 | -e 's@[^ ]*--sysroot=[^ "]*@@g' |
| 99 | |
| 100 | # The controllers memcg_stree test seems to cause us hangs and takes 900s |
| 101 | # (maybe we expect more regular output?), anyhow, skip it |
| 102 | sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 103 | |
| 104 | # We don't need to ship the compile logs that open_posix_testsuite writes |
| 105 | rm -f ${D}${prefix}/testcases/open_posix_testsuite/logfile.* |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 106 | } |
| 107 | |
| 108 | RDEPENDS:${PN} = "\ |
| 109 | attr \ |
| 110 | bash \ |
| 111 | bc \ |
| 112 | coreutils \ |
| 113 | cpio \ |
| 114 | cronie \ |
| 115 | curl \ |
| 116 | e2fsprogs \ |
| 117 | e2fsprogs-mke2fs \ |
| 118 | expect \ |
| 119 | file \ |
| 120 | gawk \ |
| 121 | gdb \ |
| 122 | gzip \ |
| 123 | iproute2 \ |
| 124 | ldd \ |
| 125 | libaio \ |
| 126 | logrotate \ |
| 127 | net-tools \ |
| 128 | perl \ |
| 129 | python3-core \ |
| 130 | procps \ |
| 131 | quota \ |
| 132 | unzip \ |
| 133 | util-linux \ |
| 134 | which \ |
| 135 | tar \ |
| 136 | " |
| 137 | |
| 138 | FILES:${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a" |
| 139 | |
| 140 | # Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail |
| 141 | INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01" |
| 142 | INSANE_SKIP:${PN} += "already-stripped staticdev" |
| 143 | |
| 144 | remove_broken_musl_sources() { |
| 145 | [ "${TCLIBC}" = "musl" ] || return 0 |
| 146 | |
| 147 | cd ${S} |
| 148 | echo "WARNING: remove unsupported tests (until they're fixed)" |
| 149 | |
| 150 | # sync with upstream |
| 151 | # https://github.com/linux-test-project/ltp/blob/master/ci/alpine.sh#L33 |
| 152 | rm -rfv \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 153 | testcases/kernel/syscalls/fmtmsg/fmtmsg01.c \ |
| 154 | testcases/kernel/syscalls/getcontext/getcontext01.c \ |
| 155 | testcases/kernel/syscalls/rt_tgsigqueueinfo/rt_tgsigqueueinfo01.c \ |
| 156 | testcases/kernel/syscalls/timer_create/timer_create01.c \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 157 | testcases/kernel/syscalls/timer_create/timer_create03.c |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 158 | } |
| 159 | do_patch[postfuncs] += "remove_broken_musl_sources" |
| 160 | |
| 161 | # Avoid file dependency scans, as LTP checks for things that may or may not |
| 162 | # exist on the running system. For instance it has specific checks for |
| 163 | # csh and ksh which are not typically part of OpenEmbedded systems (but |
| 164 | # can be added via additional layers.) |
| 165 | SKIP_FILEDEPS:${PN} = '1' |