Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 1 | DESCRIPTION = "This repository contains the source code for the ARM side \ |
| 2 | libraries used on Raspberry Pi. These typically are installed in /opt/vc/lib \ |
| 3 | and includes source for the ARM side code to interface to: EGL, mmal, GLESv2,\ |
| 4 | vcos, openmaxil, vchiq_arm, bcm_host, WFC, OpenVG." |
| 5 | LICENSE = "BSD-3-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://LICENCE;md5=0448d6488ef8cc380632b1569ee6d196" |
| 7 | |
| 8 | PR = "r5" |
| 9 | |
| 10 | PROVIDES = "virtual/libgles2 \ |
| 11 | virtual/egl" |
| 12 | |
| 13 | RPROVIDES_${PN} += "libgles2 libgl" |
| 14 | |
| 15 | COMPATIBLE_MACHINE = "raspberrypi" |
| 16 | |
| 17 | SRCBRANCH = "master" |
| 18 | SRCFORK = "raspberrypi" |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 19 | SRCREV = "bb15afe33b313fe045d52277a78653d288e04f67" |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 20 | |
| 21 | SRC_URI = "\ |
| 22 | git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \ |
| 23 | file://0001-Allow-applications-to-set-next-resource-handle.patch \ |
| 24 | file://0002-wayland-Add-support-for-the-Wayland-winsys.patch \ |
| 25 | file://0003-wayland-Add-Wayland-example.patch \ |
| 26 | file://0004-wayland-egl-Add-bcm_host-to-dependencies.patch \ |
| 27 | file://0005-interface-remove-faulty-assert-to-make-weston-happy-.patch \ |
| 28 | file://0006-zero-out-wl-buffers-in-egl_surface_free.patch \ |
| 29 | file://0007-initialize-front-back-wayland-buffers.patch \ |
| 30 | file://0008-Remove-RPC_FLUSH.patch \ |
| 31 | file://0009-fix-cmake-dependency-race.patch \ |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 32 | file://0010-Fix-for-framerate-with-nested-composition.patch \ |
| 33 | file://0011-build-shared-library-for-vchostif.patch \ |
| 34 | file://0012-implement-buffer-wrapping-interface-for-dispmanx.patch \ |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 35 | " |
| 36 | S = "${WORKDIR}/git" |
| 37 | |
| 38 | inherit cmake pkgconfig |
| 39 | |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 40 | ASNEEDED = "" |
| 41 | |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 42 | EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DCMAKE_EXE_LINKER_FLAGS='-Wl,--no-as-needed' \ |
| 43 | -DVMCS_INSTALL_PREFIX=${exec_prefix} \ |
| 44 | " |
| 45 | |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 46 | EXTRA_OECMAKE_append_aarch64 = " -DARM64=ON " |
| 47 | |
| 48 | |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 49 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}" |
| 50 | |
| 51 | PACKAGECONFIG[wayland] = "-DBUILD_WAYLAND=TRUE -DWAYLAND_SCANNER_EXECUTABLE:FILEPATH=${STAGING_BINDIR_NATIVE}/wayland-scanner,,wayland-native wayland" |
| 52 | |
| 53 | CFLAGS_append = " -fPIC" |
| 54 | |
| 55 | do_install_append () { |
| 56 | for f in `find ${D}${includedir}/interface/vcos/ -name "*.h"`; do |
| 57 | sed -i 's/include "vcos_platform.h"/include "pthreads\/vcos_platform.h"/g' ${f} |
| 58 | sed -i 's/include "vcos_futex_mutex.h"/include "pthreads\/vcos_futex_mutex.h"/g' ${f} |
| 59 | sed -i 's/include "vcos_platform_types.h"/include "pthreads\/vcos_platform_types.h"/g' ${f} |
| 60 | done |
| 61 | } |
| 62 | |
| 63 | # Shared libs from userland package build aren't versioned, so we need |
| 64 | # to force the .so files into the runtime package (and keep them |
| 65 | # out of -dev package). |
| 66 | FILES_SOLIBSDEV = "" |
| 67 | INSANE_SKIP_${PN} += "dev-so" |
| 68 | |
| 69 | FILES_${PN} += " \ |
| 70 | ${libdir}/*.so \ |
| 71 | ${libdir}/plugins" |
| 72 | FILES_${PN}-dev += "${includedir} \ |
| 73 | ${prefix}/src" |
| 74 | FILES_${PN}-doc += "${datadir}/install" |
| 75 | FILES_${PN}-dbg += "${libdir}/plugins/.debug" |
| 76 | |
| 77 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 78 | |
| 79 | RDEPENDS_${PN} += "bash" |