Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Smart card library and applications" |
| 2 | DESCRIPTION = "OpenSC is a tool for accessing smart card devices. Basic\ |
| 3 | functionality (e.g. SELECT FILE, READ BINARY) should work on any ISO\ |
| 4 | 7816-4 compatible smart card. Encryption and decryption using private\ |
| 5 | keys on the smart card is possible with PKCS\ |
| 6 | such as the FINEID (Finnish Electronic IDentity) card. Swedish Posten\ |
| 7 | eID cards have also been confirmed to work." |
| 8 | |
| 9 | HOMEPAGE = "http://www.opensc-project.org/opensc/" |
| 10 | SECTION = "System Environment/Libraries" |
| 11 | LICENSE = "LGPLv2+" |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=cb8aedd3bced19bd8026d96a8b6876d7" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 14 | #v0.21.0 |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 15 | SRCREV = "c902e1992195e00ada12d71beb1029287cd72037" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 16 | SRC_URI = "git://github.com/OpenSC/OpenSC;branch=master;protocol=https \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 17 | " |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 18 | DEPENDS = "virtual/libiconv openssl" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | inherit autotools pkgconfig bash-completion |
| 22 | |
| 23 | EXTRA_OECONF = " \ |
| 24 | --disable-static \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 25 | --disable-ctapi \ |
| 26 | --disable-doc \ |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 27 | --disable-strict \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | " |
| 29 | EXTRA_OEMAKE = "DESTDIR=${D}" |
| 30 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 31 | PACKAGECONFIG ??= "pcsc" |
| 32 | |
| 33 | PACKAGECONFIG[openct] = "--enable-openct,--disable-openct,openct" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 34 | PACKAGECONFIG[pcsc] = "--enable-pcsc,--disable-pcsc,pcsc-lite,pcsc-lite pcsc-lite-lib" |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 35 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | RDEPENDS:${PN} = "readline" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | FILES:${PN} += "\ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 39 | ${libdir}/opensc-pkcs11.so \ |
| 40 | ${libdir}/onepin-opensc-pkcs11.so \ |
| 41 | ${libdir}/pkcs11-spy.so \ |
| 42 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 43 | FILES:${PN}-dev += "\ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 44 | ${libdir}/pkcs11/opensc-pkcs11.so \ |
| 45 | ${libdir}/pkcs11/onepin-opensc-pkcs11.so \ |
| 46 | ${libdir}/pkcs11/pkcs11-spy.so \ |
| 47 | " |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 48 | |
| 49 | BBCLASSEXTEND = "native" |