Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "A high performance, open source, general-purpose RPC framework. \ |
| 2 | Provides gRPC libraries for multiple languages written on top of shared C core library \ |
| 3 | (C++, Node.js, Python, Ruby, Objective-C, PHP, C#)" |
| 4 | HOMEPAGE = "https://github.com/grpc/grpc" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "Apache-2" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 8 | |
| 9 | DEPENDS = "gflags c-ares protobuf protobuf-native protobuf-c protobuf-c-native openssl" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 10 | DEPENDS_append_class-target = " googletest grpc-native " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | DEPENDS_append_class-nativesdk = " grpc-native " |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
Brad Bishop | 63ae878 | 2019-10-09 09:56:13 -0400 | [diff] [blame^] | 14 | SRCREV_grpc = "fe494ff4104b6f6a78117ab2da71d29c93053267" |
| 15 | SRCREV_upb = "9effcbcb27f0a665f9f345030188c0b291e32482" |
| 16 | BRANCH = "v1.24.x" |
| 17 | SRC_URI = "git://github.com/grpc/grpc.git;protocol=https;name=grpc;branch=${BRANCH} \ |
| 18 | git://github.com/protocolbuffers/upb;name=upb;destsuffix=git/third_party/upb \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | file://0001-CMakeLists.txt-Fix-libraries-installation-for-Linux.patch \ |
| 20 | " |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 21 | SRC_URI_append_class-target = " file://0001-CMakeLists.txt-Fix-grpc_cpp_plugin-path-during-cross.patch \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 22 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | SRC_URI_append_class-nativesdk = " file://0001-CMakeLists.txt-Fix-grpc_cpp_plugin-path-during-cross.patch" |
| 24 | |
| 25 | # Fixes build with older compilers 4.8 especially on ubuntu 14.04 |
| 26 | CXXFLAGS_append_class-native = " -Wl,--no-as-needed" |
| 27 | |
Brad Bishop | 63ae878 | 2019-10-09 09:56:13 -0400 | [diff] [blame^] | 28 | inherit cmake pkgconfig |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | |
| 30 | EXTRA_OECMAKE = " \ |
| 31 | -DgRPC_CARES_PROVIDER=package \ |
| 32 | -DgRPC_ZLIB_PROVIDER=package \ |
| 33 | -DgRPC_SSL_PROVIDER=package \ |
| 34 | -DgRPC_PROTOBUF_PROVIDER=package \ |
| 35 | -DgRPC_GFLAGS_PROVIDER=package \ |
| 36 | -DgRPC_INSTALL=ON \ |
| 37 | -DCMAKE_CROSSCOMPILING=ON \ |
| 38 | -DBUILD_SHARED_LIBS=ON \ |
| 39 | " |
| 40 | |
Brad Bishop | 63ae878 | 2019-10-09 09:56:13 -0400 | [diff] [blame^] | 41 | do_configure_prepend_mipsarch() { |
| 42 | sed -i -e "s/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} rt m pthread)/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} atomic rt m pthread)/g" ${S}/CMakeLists.txt |
| 43 | } |
| 44 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 45 | BBCLASSEXTEND = "native nativesdk" |
| 46 | |
| 47 | SYSROOT_DIRS_BLACKLIST_append_class-target = "${libdir}/cmake/grpc" |
| 48 | |
| 49 | FILES_${PN}-dev += "${bindir}" |