Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Python bindings for GStreamer 1.0" |
| 2 | HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/" |
| 3 | SECTION = "multimedia" |
| 4 | |
| 5 | LICENSE = "LGPLv2.1" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740" |
| 7 | |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame^] | 8 | SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz" |
| 9 | SRC_URI[md5sum] = "499645fbd1790c5845c02a3998dccc1b" |
| 10 | SRC_URI[sha256sum] = "b469c8955126f41b8ce0bf689b7029f182cd305f422b3a8df35b780bd8347489" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | |
| 12 | DEPENDS = "gstreamer1.0 python3-pygobject" |
| 13 | RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject" |
| 14 | |
| 15 | PNREAL = "gst-python" |
| 16 | |
| 17 | S = "${WORKDIR}/${PNREAL}-${PV}" |
| 18 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 19 | # gobject-introspection is mandatory and cannot be configured |
| 20 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| 21 | UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection" |
| 22 | |
| 23 | inherit autotools pkgconfig distutils3-base upstream-version-is-even gobject-introspection distro_features_check |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 25 | EXTRA_OECONF += "--with-libpython-dir=${libdir}" |
| 26 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 27 | do_install_append() { |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 28 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | # Note that this particular find line is taken from the Debian packaging for |
| 30 | # gst-python1.0. |
| 31 | find "${D}" \ |
| 32 | -name '*.pyc' -o \ |
| 33 | -name '*.pyo' -o \ |
| 34 | -name '*.la' -o \ |
| 35 | -name 'libgstpythonplugin*' \ |
| 36 | -delete |
| 37 | } |