Adriana Kobylak | f20b3aa | 2017-04-28 16:05:39 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenPower Software Management" |
| 2 | DESCRIPTION = "OpenPower Software Manager provides a set of host software \ |
| 3 | management daemons. It is suitable for use on a wide variety of OpenPower \ |
| 4 | platforms." |
| 5 | HOMEPAGE = "https://github.com/openbmc/openpower-pnor-code-mgmt" |
| 6 | PR = "r1" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 9 | |
| 10 | inherit autotools pkgconfig |
| 11 | inherit obmc-phosphor-dbus-service |
| 12 | |
| 13 | DEPENDS += " \ |
| 14 | autoconf-archive-native \ |
| 15 | phosphor-dbus-interfaces \ |
| 16 | phosphor-logging \ |
| 17 | sdbusplus \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS_${PN} += " \ |
| 21 | mtd-utils-ubifs \ |
| 22 | phosphor-dbus-interfaces \ |
| 23 | phosphor-logging \ |
| 24 | sdbusplus \ |
| 25 | " |
| 26 | |
Adriana Kobylak | 69d3de0 | 2017-05-25 15:48:27 -0500 | [diff] [blame^] | 27 | S = "${WORKDIR}" |
| 28 | SRC_URI += " \ |
| 29 | file://bios-ubiattach \ |
| 30 | file://bios-ubiformat" |
| 31 | |
| 32 | do_install() { |
| 33 | install -d ${D}${sbindir} |
| 34 | install -m 0755 ${WORKDIR}/bios-ubiattach ${D}${sbindir}/bios-ubiattach |
| 35 | install -m 0755 ${WORKDIR}/bios-ubiformat ${D}${sbindir}/bios-ubiformat |
| 36 | } |
| 37 | |
Adriana Kobylak | f20b3aa | 2017-04-28 16:05:39 -0500 | [diff] [blame] | 38 | DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service" |
| 39 | SYSTEMD_SERVICE_${PN} += " \ |
| 40 | obmc-flash-bios-ubiattach.service \ |
| 41 | obmc-flash-bios-ubimount@.service \ |
Adriana Kobylak | 7f01f21 | 2017-05-22 14:41:02 -0500 | [diff] [blame] | 42 | obmc-flash-bios-ubiumount-prsv.service \ |
| 43 | obmc-flash-bios-ubiumount-rw@.service \ |
Adriana Kobylak | f20b3aa | 2017-04-28 16:05:39 -0500 | [diff] [blame] | 44 | obmc-flash-bios-squashfsmount@.service \ |
| 45 | " |
| 46 | |
| 47 | SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt" |
Patrick Williams | 313b7b2 | 2017-05-31 09:50:02 -0500 | [diff] [blame] | 48 | SRCREV = "3accb3221efd3cfc7d409438bee5a1801c2561dc" |
Adriana Kobylak | f20b3aa | 2017-04-28 16:05:39 -0500 | [diff] [blame] | 49 | |
| 50 | S = "${WORKDIR}/git" |