blob: 882eada7a4e8bb7609699d2e39c5b5c9fbff1a68 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
Brad Bishop19323692019-04-05 15:28:33 -040014GNOMEBASEBUILDCLASS = "meson"
15
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
17
Brad Bishopc68388fc2019-08-26 01:33:31 -040018SRC_URI += "file://run-ptest"
Brad Bishop79641f22019-09-10 07:20:22 -040019SRC_URI[archive.md5sum] = "db0a3243ba33e02aaa775412f8e5f412"
20SRC_URI[archive.sha256sum] = "3e1e41ba838737e200611ff001e3b304c2ca4cdbba63d200a20db0b0ddc0f86c"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021
22DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
23
Brad Bishop08902b02019-08-20 09:16:51 -040024PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
25 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
Brad Bishop19323692019-04-05 15:28:33 -040026
Brad Bishop08902b02019-08-20 09:16:51 -040027PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
28PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
Brad Bishop79641f22019-09-10 07:20:22 -040029PACKAGECONFIG[thai] = ",,libthai"
Brad Bishop08902b02019-08-20 09:16:51 -040030
31GTKDOC_MESON_OPTION = "gtk_doc"
32GIR_MESON_OPTION = 'introspection'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033
34LEAD_SONAME = "libpango-1.0*"
35LIBV = "1.8.0"
36
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080037FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
38FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la"
39
Brad Bishopc68388fc2019-08-26 01:33:31 -040040RDEPENDS_${PN}-ptest += "cantarell-fonts"
41RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080042
43RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
44 pango-module-basic-fc pango-module-arabic-lang"
45
Brad Bishop19323692019-04-05 15:28:33 -040046BBCLASSEXTEND = "native nativesdk"