Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Memory Efficient Serialization Library" |
| 2 | HOMEPAGE = "https://github.com/google/flatbuffers" |
| 3 | SECTION = "console/tools" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | |
| 6 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 7 | |
| 8 | RDEPENDS_${PN}-compiler = "${PN}" |
| 9 | RDEPENDS_${PN}-dev += "${PN}-compiler" |
| 10 | |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 12 | |
| 13 | SRCREV = "6df40a2471737b27271bdd9b900ab5f3aec746c7" |
| 14 | |
| 15 | SRC_URI = "git://github.com/google/flatbuffers.git" |
| 16 | |
Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 17 | CXXFLAGS += "-fPIC" |
| 18 | BUILD_CXXFLAGS += "-fPIC" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | |
| 20 | # BUILD_TYPE=Release is required, otherwise flatc is not installed |
| 21 | EXTRA_OECMAKE += "\ |
| 22 | -DCMAKE_BUILD_TYPE=Release \ |
| 23 | -DFLATBUFFERS_BUILD_TESTS=OFF \ |
| 24 | -DFLATBUFFERS_BUILD_SHAREDLIB=ON \ |
| 25 | " |
| 26 | |
| 27 | inherit cmake |
| 28 | |
| 29 | S = "${WORKDIR}/git" |
| 30 | |
| 31 | FILES_${PN}-compiler = "${bindir}" |
| 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |