Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "Xilinx Runtime(XRT) libraries" |
| 2 | DESCRIPTION = "Xilinx Runtime User Space Libraries and headers" |
| 3 | |
| 4 | LICENSE = "GPLv2 & Apache-2.0" |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=da5408f748bce8a9851dac18e66f4bcf \ |
| 6 | file://runtime_src/core/edge/drm/zocl/LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8 \ |
| 7 | file://runtime_src/core/pcie/driver/linux/xocl/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 8 | file://runtime_src/core/pcie/linux/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \ |
| 9 | file://runtime_src/core/pcie/tools/xbutil/LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87 \ |
| 10 | file://runtime_src/core/edge/tools/xbutil/LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87 " |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 11 | |
Andrew Geissler | 7eb438a | 2020-11-30 19:53:16 -0600 | [diff] [blame^] | 12 | BRANCH ?= "2020.2" |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 13 | REPO ?= "git://github.com/Xilinx/XRT.git;protocol=https" |
| 14 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" |
| 15 | SRC_URI = "${REPO};${BRANCHARG}" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 16 | |
Andrew Geissler | 7eb438a | 2020-11-30 19:53:16 -0600 | [diff] [blame^] | 17 | FILESEXTRAPATHS_prepend := "${THISDIR}/xrt:" |
| 18 | SRC_URI_append = " file://0001-Replace-boost-detail-endian.hpp-with-boost-predef-ot.patch" |
| 19 | PV = "202020.2.8.0" |
| 20 | SRCREV ?= "f19a872233fbfe2eb933f25fa3d9a780ced774e5" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 21 | |
| 22 | S = "${WORKDIR}/git/src" |
| 23 | |
| 24 | inherit cmake |
| 25 | |
| 26 | BBCLASSEXTEND = "native nativesdk" |
| 27 | |
| 28 | # util-linux is for libuuid-dev. |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 29 | DEPENDS = "libdrm opencl-headers ocl-icd opencl-clhpp boost util-linux git-replacement-native protobuf-native protobuf" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 30 | RDEPENDS_${PN} = "bash ocl-icd boost-system boost-filesystem" |
| 31 | |
| 32 | EXTRA_OECMAKE += " \ |
| 33 | -DCMAKE_BUILD_TYPE=Release \ |
| 34 | -DCMAKE_EXPORT_COMPILE_COMANDS=ON \ |
| 35 | " |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 36 | |
Andrew Geissler | a9ff2b3 | 2020-10-16 10:11:54 -0500 | [diff] [blame] | 37 | PACKAGE_ARCH_versal-ai-core = "${SOC_VARIANT_ARCH}" |
| 38 | EXTRA_OECMAKE_append_versal-ai-core += "-DXRT_AIE_BUILD=true" |
| 39 | TARGET_CXXFLAGS_append_versal-ai-core += "-DXRT_ENABLE_AIE" |
| 40 | DEPENDS_append_versal-ai-core += " libmetal libxaiengine" |
| 41 | RDEPENDS_${PN}_append_versal-ai-core += " libxaiengine" |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 42 | |
Andrew Geissler | 7eb438a | 2020-11-30 19:53:16 -0600 | [diff] [blame^] | 43 | FILES_SOLIBSDEV = "" |
| 44 | FILES_${PN} += "\ |
| 45 | ${libdir}/lib*.so \ |
| 46 | ${libdir}/lib*.so.* \ |
| 47 | /lib/*.so* " |
| 48 | INSANE_SKIP_${PN} += "dev-so" |
| 49 | |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 50 | pkg_postinst_ontarget_${PN}() { |
| 51 | #!/bin/sh |
| 52 | if [ ! -e /etc/OpenCL/vendors/xilinx.icd ]; then |
| 53 | echo "INFO: Creating ICD entry for Xilinx Platform" |
| 54 | mkdir -p /etc/OpenCL/vendors |
| 55 | echo "libxilinxopencl.so" > /etc/OpenCL/vendors/xilinx.icd |
| 56 | chmod -R 755 /etc/OpenCL |
| 57 | fi |
| 58 | } |