blob: 759d1087c05596cfa14895e54e42433b4151519a [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Filesystem and hardware benchmark and stress tool"
2DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \
3stress/hardware verification. It has support for a number of I/O engines, \
4I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \
5and much more. It can work on block devices as well as files. fio accepts \
6job descriptions in a simple-to-understand text format. Several example job \
7files are included. fio displays all sorts of I/O performance information."
8HOMEPAGE = "http://freecode.com/projects/fio"
9SECTION = "console/tests"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
Brad Bishop63ae8782019-10-09 09:56:13 -040013DEPENDS = "libaio zlib coreutils-native"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014DEPENDS += "${@bb.utils.contains('MACHINE_FEATURES', 'pmem', 'pmdk', '', d)}"
15RDEPENDS_${PN} = "python3-core bash"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016
17PACKAGECONFIG_NUMA = "numa"
18# ARM does not currently support NUMA
19PACKAGECONFIG_NUMA_arm = ""
Brad Bishop34ae6002019-04-08 15:21:03 -040020PACKAGECONFIG_NUMA_armeb = ""
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021
22PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}"
23PACKAGECONFIG[numa] = ",--disable-numa,numactl"
24
Brad Bishop0e2770c2020-01-21 07:31:46 -050025SRCREV = "08ce9dc20b8a4e55db7af6d869ddfa49b4a02d03"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026SRC_URI = "git://git.kernel.dk/fio.git \
27 file://0001-update-the-interpreter-paths.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050028 file://python3_shebangs.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029"
30
31S = "${WORKDIR}/git"
32
33# avoids build breaks when using no-static-libs.inc
34DISABLE_STATIC = ""
35
36EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'"
Andrew Geissler82c905d2020-04-13 13:39:40 -050037EXTRA_OECONF = "${@bb.utils.contains('MACHINE_FEATURES', 'x86', '--disable-optimizations', '', d)}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038
39do_configure() {
40 ./configure ${EXTRA_OECONF}
41}
42
43do_install() {
44 oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir}
45 install -d ${D}/${docdir}/${PN}
46 cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/
47}