Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "USB CEC Adaptor communication Library" |
| 2 | HOMEPAGE = "http://libcec.pulse-eight.com/" |
| 3 | |
| 4 | LICENSE = "GPLv2+" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b3a719e97f49e4841e90573f9b1a98ac" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | DEPENDS = "p8platform udev ncurses swig-native python3" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 9 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}" |
| 10 | DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 12 | PV = "5.0.0" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 13 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 14 | SRCREV = "43bc27fe7be491149e6f57d14110e02abdac2f24" |
| 15 | SRC_URI = "git://github.com/Pulse-Eight/libcec.git;branch=release \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 16 | file://0001-CheckPlatformSupport.cmake-Do-not-hardcode-lib-path.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 17 | file://0001-Enhance-reproducibility.patch \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 18 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 22 | inherit cmake pkgconfig |
| 23 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | # Put client tools into a separate package |
| 25 | PACKAGE_BEFORE_PN += "${PN}-tools" |
| 26 | FILES_${PN}-tools = "${bindir}" |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame] | 27 | RDEPENDS_${PN}-tools = "python3-${BPN} python3-core" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 29 | # Create the wrapper for python3 |
| 30 | PACKAGES += "python3-${BPN}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | FILES_python3-${BPN} = "${libdir}/python3* ${bindir}/py*" |
| 32 | RDEPENDS_${PN} = "python3-core" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 33 | |
| 34 | # cec-client and xbmc need the .so present to work :( |
| 35 | FILES_${PN} += "${libdir}/*.so" |
| 36 | INSANE_SKIP_${PN} = "dev-so" |
| 37 | |
| 38 | # Adapter shows up as a CDC-ACM device |
| 39 | RRECOMMENDS_${PN} = "kernel-module-cdc-acm" |