Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "open-source formatting library for C++" |
| 2 | DESCRIPTION = "{fmt} is an open-source formatting library for C++. It can be used as a safe and fast alternative to (s)printf and iostreams." |
| 3 | HOMEPAGE = "https://fmt.dev" |
Brad Bishop | 7e36d53 | 2019-09-16 07:44:26 -0400 | [diff] [blame] | 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=af88d758f75f3c5c48a967501f24384b" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 6 | |
| 7 | SRC_URI += "git://github.com/fmtlib/fmt" |
Brad Bishop | 7e36d53 | 2019-09-16 07:44:26 -0400 | [diff] [blame] | 8 | SRCREV = "7512a55aa3ae309587ca89668ef9ec4074a51a1f" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | inherit cmake |
| 13 | inherit ptest |
| 14 | |
| 15 | EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON" |