blob: eb6c7a3a6ad9ae0935fc9ff411783b35bdcf6107 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Additional utilities for the opkg package manager"
2SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system"
3SECTION = "base"
4HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://opkg.py;beginline=2;endline=18;md5=63ce9e6bcc445181cd9e4baf4b4ccc35"
8PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}"
9
10SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \
11 file://0001-Switch-all-scripts-to-use-Python-3.x.patch \
Brad Bishopa34c0302019-09-23 22:34:48 -040012 file://0001-opkg-build-clamp-mtimes-to-SOURCE_DATE_EPOCH.patch \
Brad Bishop6dbb3162019-11-25 09:41:34 -050013 file://pipefail.patch \
Brad Bishop19323692019-04-05 15:28:33 -040014"
15UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/"
16
17
Brad Bishop15ae2502019-06-18 21:44:24 -040018SRC_URI[md5sum] = "8c140f835b694a0c27cfb23d2426a02b"
19SRC_URI[sha256sum] = "9ea9efdd9fe13661ad251e3a2860c1c93045adcfaa6659c3e86d9748ecda3b6e"
Brad Bishop19323692019-04-05 15:28:33 -040020
21TARGET_CC_ARCH += "${LDFLAGS}"
22
Brad Bishop6dbb3162019-11-25 09:41:34 -050023RDEPENDS_${PN} += "bash"
24
Brad Bishop19323692019-04-05 15:28:33 -040025# For native builds we use the host Python
26PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold"
27PYTHONRDEPS_class-native = ""
28
29PACKAGECONFIG = "python update-alternatives"
30PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}"
31PACKAGECONFIG[update-alternatives] = ",,,"
32
33do_install() {
34 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
35 if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then
36 rm -f "${D}${bindir}/update-alternatives"
37 fi
38
39 if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
40 grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm
41 fi
42}
43
44do_install_append_class-target() {
45 if [ -e "${D}${bindir}/update-alternatives" ]; then
46 sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g'
47 fi
48}
49
50# These are empty and will pull python3-dev into images where it wouldn't
51# have been otherwise, so don't generate them.
52PACKAGES_remove = "${PN}-dev ${PN}-staticdev"
53
54PACKAGES =+ "update-alternatives-opkg"
55FILES_update-alternatives-opkg = "${bindir}/update-alternatives"
56RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth"
57RREPLACES_update-alternatives-opkg = "update-alternatives-cworth"
58RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth"
59
60pkg_postrm_update-alternatives-opkg() {
61 rm -rf $D${nonarch_libdir}/opkg/alternatives
62 rmdir $D${nonarch_libdir}/opkg || true
63}
64
65BBCLASSEXTEND = "native nativesdk"
66
67CLEANBROKEN = "1"