Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Additional utilities for the opkg package manager" |
| 2 | SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system" |
| 3 | SECTION = "base" |
| 4 | HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils" |
| 5 | LICENSE = "GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 7 | file://opkg.py;beginline=2;endline=18;md5=63ce9e6bcc445181cd9e4baf4b4ccc35" |
| 8 | PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}" |
| 9 | |
| 10 | SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \ |
| 11 | file://0001-Switch-all-scripts-to-use-Python-3.x.patch \ |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 12 | file://0001-opkg-build-clamp-mtimes-to-SOURCE_DATE_EPOCH.patch \ |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 13 | file://pipefail.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | " |
| 15 | UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/" |
| 16 | |
| 17 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 18 | SRC_URI[md5sum] = "8c140f835b694a0c27cfb23d2426a02b" |
| 19 | SRC_URI[sha256sum] = "9ea9efdd9fe13661ad251e3a2860c1c93045adcfaa6659c3e86d9748ecda3b6e" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 20 | |
| 21 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 22 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 23 | RDEPENDS_${PN} += "bash" |
| 24 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 25 | # For native builds we use the host Python |
| 26 | PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold" |
| 27 | PYTHONRDEPS_class-native = "" |
| 28 | |
| 29 | PACKAGECONFIG = "python update-alternatives" |
| 30 | PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}" |
| 31 | PACKAGECONFIG[update-alternatives] = ",,," |
| 32 | |
| 33 | do_install() { |
| 34 | oe_runmake PREFIX=${prefix} DESTDIR=${D} install |
| 35 | if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then |
| 36 | rm -f "${D}${bindir}/update-alternatives" |
| 37 | fi |
| 38 | |
| 39 | if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then |
| 40 | grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm |
| 41 | fi |
| 42 | } |
| 43 | |
| 44 | do_install_append_class-target() { |
| 45 | if [ -e "${D}${bindir}/update-alternatives" ]; then |
| 46 | sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g' |
| 47 | fi |
| 48 | } |
| 49 | |
| 50 | # These are empty and will pull python3-dev into images where it wouldn't |
| 51 | # have been otherwise, so don't generate them. |
| 52 | PACKAGES_remove = "${PN}-dev ${PN}-staticdev" |
| 53 | |
| 54 | PACKAGES =+ "update-alternatives-opkg" |
| 55 | FILES_update-alternatives-opkg = "${bindir}/update-alternatives" |
| 56 | RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth" |
| 57 | RREPLACES_update-alternatives-opkg = "update-alternatives-cworth" |
| 58 | RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth" |
| 59 | |
| 60 | pkg_postrm_update-alternatives-opkg() { |
| 61 | rm -rf $D${nonarch_libdir}/opkg/alternatives |
| 62 | rmdir $D${nonarch_libdir}/opkg || true |
| 63 | } |
| 64 | |
| 65 | BBCLASSEXTEND = "native nativesdk" |
| 66 | |
| 67 | CLEANBROKEN = "1" |