Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 1 | SUMMARY = "Window navigation construction toolkit" |
| 2 | LICENSE = "LGPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
| 4 | |
| 5 | GNOMEBASEBUILDCLASS = "meson" |
| 6 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 7 | inherit gnomebase gsettings gobject-introspection gettext features_check upstream-version-is-even |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 8 | |
| 9 | SRC_URI[archive.md5sum] = "528b0b7cc2dd22c6026a9c8739c71fa7" |
| 10 | SRC_URI[archive.sha256sum] = "7ce4979817866911a94ecb75b36db56797e038c0c524c5c1a81aefccafc17337" |
| 11 | |
| 12 | DEPENDS = " \ |
| 13 | colord \ |
| 14 | geocode-glib \ |
| 15 | gcr \ |
| 16 | gnome-desktop3 \ |
| 17 | libgweather \ |
| 18 | lcms \ |
| 19 | libcanberra \ |
| 20 | geoclue \ |
| 21 | libnotify \ |
| 22 | upower \ |
| 23 | libwacom \ |
| 24 | virtual/libx11 \ |
| 25 | " |
| 26 | |
| 27 | # all these are mandatory |
| 28 | REQUIRED_DISTRO_FEATURES = "x11 polkit pulseaudio systemd gobject-introspection-data" |
| 29 | UNKNOWN_CONFIGURE_WHITELIST_append = " introspection" |
| 30 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame^] | 31 | SRC_URI[archive.md5sum] = "102dc488a6a726e4050cf5ab7e967e8d" |
| 32 | SRC_URI[archive.sha256sum] = "3e33dbd319b562a5ab602dcab6de3ca81b85f8346672e90ec632b36bbf15ee4b" |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 33 | |
| 34 | # allow cross build mixed with build of native tools |
| 35 | do_write_config_append() { |
| 36 | cat >${WORKDIR}/meson.native <<EOF |
| 37 | [binaries] |
| 38 | pkgconfig = 'pkg-config-native' |
| 39 | EOF |
| 40 | } |
| 41 | EXTRA_OEMESON = "--native-file ${WORKDIR}/meson.native" |
| 42 | |
| 43 | PACKAGECONFIG ??= " \ |
| 44 | cups nm \ |
| 45 | alsa gudev \ |
| 46 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)} \ |
| 47 | " |
| 48 | PACKAGECONFIG[alsa] = "-Dalsa=true,-Dalsa=false,alsa-lib" |
| 49 | PACKAGECONFIG[cups] = "-Dcups=true,-Dcups=false,cups" |
| 50 | PACKAGECONFIG[gudev] = "-Dgudev=true,-Dgudev=false,libgudev" |
| 51 | PACKAGECONFIG[nm] = "-Dnetwork_manager=true,-Dnetwork_manager=false,networkmanager" |
| 52 | PACKAGECONFIG[wayland] = "-Dwayland=true,-Dwayland=false,wayland" |
| 53 | |
| 54 | FILES_${PN} += " \ |
| 55 | ${systemd_user_unitdir} \ |
| 56 | ${libdir}/gnome-settings-daemon-3.0/libgsd.so \ |
| 57 | " |
| 58 | |
| 59 | RDEPEND_${PN} += "gdbus" |