blob: 065d0eae1af83918d0cc88507a78ffa96f623431 [file] [log] [blame]
Patrick Williamsd849ec72016-08-17 14:59:38 -05001SECTION = "devel"
2SUMMARY = "Light-weight package to set up cgroups at system boot."
3DESCRIPTION = "Light-weight package to set up cgroups at system boot."
4HOMEPAGE = "http://packages.ubuntu.com/source/precise/cgroup-lite"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://debian/copyright;md5=5d5da4e0867cf06014f87102154d0102"
Patrick Williamse69d2352017-02-23 20:56:04 -06007SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/cgroup-lite_1.11.tar.xz"
Patrick Williamsd849ec72016-08-17 14:59:38 -05008SRC_URI += "file://cgroups-init"
Patrick Williamse69d2352017-02-23 20:56:04 -06009SRC_URI[md5sum] = "b20976194ee8fdb61e6b55281fb6ead4"
10SRC_URI[sha256sum] = "a79ab9ae6fb3ff3ce0aa5539b055c0379eaffdc6c5f003af4010fcea683c1a45"
Patrick Williamsd849ec72016-08-17 14:59:38 -050011
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012inherit allarch
Patrick Williamsd849ec72016-08-17 14:59:38 -050013inherit update-rc.d
14
15INITSCRIPT_NAME = "cgroups-init"
16INITSCRIPT_PARAMS = "start 8 2 3 4 5 . stop 20 0 1 6 ."
17do_install() {
18 install -d ${D}/bin
19 install -d ${D}${sysconfdir}/init.d
20 install -m 0755 ${S}/scripts/cgroups-mount ${D}/bin
21 install -m 0755 ${S}/scripts/cgroups-umount ${D}/bin
22 install -m 0755 ${WORKDIR}/cgroups-init ${D}${sysconfdir}/init.d/cgroups-init
23}