Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | DESCRIPTION = "A modern, C++-native, header-only, test framework for unit-tests, \ |
| 2 | TDD and BDD - using C++11, C++14, C++17 and later." |
| 3 | AUTHOR = "Phil Nash, Martin Horenovsky and others" |
| 4 | HOMEPAGE = "https://github.com/catchorg/Catch2" |
| 5 | LICENSE = "BSL-1.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c" |
| 7 | |
Brad Bishop | b809eb9 | 2019-09-18 06:27:43 -0400 | [diff] [blame] | 8 | SRC_URI = "git://github.com/catchorg/Catch2.git" |
| 9 | SRCREV = "2c869e17e4803d30b3d5ca5b0d76387b9db97fa5" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit cmake python3native |
| 14 | |
| 15 | do_install_append() { |
| 16 | rm ${D}${datadir}/Catch2/lldbinit |
| 17 | rm ${D}${datadir}/Catch2/gdbinit |
| 18 | rmdir ${D}${datadir}/Catch2/ |
| 19 | } |
| 20 | # Header-only library |
| 21 | RDEPENDS_${PN}-dev = "" |
| 22 | RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})" |