blob: fe7b760e22140959c00d7140c8bb4a2d58f7e7e5 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Persistent Memory Development Kit"
2DESCRIPTION = "Persistent Memory Development Kit"
3HOMEPAGE = "http://pmem.io"
4SECTION = "libs"
Brad Bishop2d39a062019-10-28 08:33:36 -04005LICENSE = "BSD-3-Clause"
Andrew Geissler7f40b712020-05-15 14:09:53 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=1b8430f251523f1bff0c9fb95da7e0ca"
Brad Bishop26bdd442019-08-16 17:08:17 -04007DEPENDS = "ndctl"
8
9# Required to have the fts.h header for musl
10DEPENDS_append_libc-musl = " fts"
11
12S = "${WORKDIR}/git"
13
14SRC_URI = "git://github.com/pmem/pmdk.git \
Andrew Geissler7f40b712020-05-15 14:09:53 -050015 file://0001-examples-Initialize-child_idx.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040016 file://0002-Makefile-Don-t-install-the-docs.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040017 "
18
Andrew Geissler7f40b712020-05-15 14:09:53 -050019SRCREV = "0245d75eaf0f6106c86a7926a45fdf2149e37eaa"
Brad Bishop26bdd442019-08-16 17:08:17 -040020
21inherit autotools-brokensep pkgconfig
22
23# Fix jemalloc error:
24# | configure: error: cannot run C compiled programs.
25# | If you meant to cross compile, use `--host'.
26#
27# Also fix #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Werror=cpp]
Brad Bishop63ae8782019-10-09 09:56:13 -040028EXTRA_OEMAKE = "BUILD_EXAMPLES='n' HOST_SYS='${HOST_SYS}' EXTRA_CFLAGS='${SELECTED_OPTIMIZATION}' LIB_PREFIX=${baselib}"
Brad Bishop26bdd442019-08-16 17:08:17 -040029
30# Fix the missing fts libs when using musl
31EXTRA_OEMAKE_append_libc-musl = " EXTRA_LIBS='-lfts'"
32
Andrew Geissler7f40b712020-05-15 14:09:53 -050033do_configure_prepend() {
34 touch .skip-doc
35}
36
Brad Bishop26bdd442019-08-16 17:08:17 -040037do_install() {
38 oe_runmake prefix=${prefix} DESTDIR=${D} install
39
40 # Remove uneeded files
41 rm -rf ${D}/usr/${baselib}/pmdk_debug
42}
43
44# Include these by default otherwise the SDK is not very useful
45FILES_${PN} += "${bindir}/pmempool ${bindir}/daxio"
46FILES_${PN} += "${libdir}/*so*"
47FILES_${PN} += "${libdir}/pkgconfig/*.pc"
48FILES_${PN} += "${includedir}/libpmemobj++/* ${includedir}/libpmemobj/* /usr/*/include/"
49FILES_${PN} += "/usr/etc"
50FILES_${PN} += "/usr/share"
51
52COMPATIBLE_HOST='(x86_64).*'