Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "Persistent Memory Development Kit" |
| 2 | DESCRIPTION = "Persistent Memory Development Kit" |
| 3 | HOMEPAGE = "http://pmem.io" |
| 4 | SECTION = "libs" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 5 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1b8430f251523f1bff0c9fb95da7e0ca" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 7 | DEPENDS = "ndctl" |
| 8 | |
| 9 | # Required to have the fts.h header for musl |
| 10 | DEPENDS_append_libc-musl = " fts" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | SRC_URI = "git://github.com/pmem/pmdk.git \ |
Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 15 | file://0001-examples-Initialize-child_idx.patch \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 16 | file://0002-Makefile-Don-t-install-the-docs.patch \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 17 | " |
| 18 | |
Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 19 | SRCREV = "0245d75eaf0f6106c86a7926a45fdf2149e37eaa" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 20 | |
| 21 | inherit autotools-brokensep pkgconfig |
| 22 | |
| 23 | # Fix jemalloc error: |
| 24 | # | configure: error: cannot run C compiled programs. |
| 25 | # | If you meant to cross compile, use `--host'. |
| 26 | # |
| 27 | # Also fix #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Werror=cpp] |
Brad Bishop | 63ae878 | 2019-10-09 09:56:13 -0400 | [diff] [blame] | 28 | EXTRA_OEMAKE = "BUILD_EXAMPLES='n' HOST_SYS='${HOST_SYS}' EXTRA_CFLAGS='${SELECTED_OPTIMIZATION}' LIB_PREFIX=${baselib}" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 29 | |
| 30 | # Fix the missing fts libs when using musl |
| 31 | EXTRA_OEMAKE_append_libc-musl = " EXTRA_LIBS='-lfts'" |
| 32 | |
Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 33 | do_configure_prepend() { |
| 34 | touch .skip-doc |
| 35 | } |
| 36 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 37 | do_install() { |
| 38 | oe_runmake prefix=${prefix} DESTDIR=${D} install |
| 39 | |
| 40 | # Remove uneeded files |
| 41 | rm -rf ${D}/usr/${baselib}/pmdk_debug |
| 42 | } |
| 43 | |
| 44 | # Include these by default otherwise the SDK is not very useful |
| 45 | FILES_${PN} += "${bindir}/pmempool ${bindir}/daxio" |
| 46 | FILES_${PN} += "${libdir}/*so*" |
| 47 | FILES_${PN} += "${libdir}/pkgconfig/*.pc" |
| 48 | FILES_${PN} += "${includedir}/libpmemobj++/* ${includedir}/libpmemobj/* /usr/*/include/" |
| 49 | FILES_${PN} += "/usr/etc" |
| 50 | FILES_${PN} += "/usr/share" |
| 51 | |
| 52 | COMPATIBLE_HOST='(x86_64).*' |