Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 1 | SUMMARY = "OpenGL / OpenGL ES Reference Compiler" |
| 2 | DESCRIPTION = "Glslang is the official reference compiler front end for the \ |
| 3 | OpenGL ES and OpenGL shading languages. It implements a strict interpretation \ |
| 4 | of the specifications for these languages. It is open and free for anyone to use, \ |
| 5 | either from a command line or programmatically." |
| 6 | SECTION = "graphics" |
| 7 | HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler" |
| 8 | LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c5ce49c0456e9b413b98a4368c378229" |
| 10 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 11 | SRCREV = "5421877c380d5f92c1965c7a94620dac861297dd" |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 12 | SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https \ |
| 13 | file://0001-generate-glslang-pkg-config.patch" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 14 | UPSTREAM_CHECK_GITTAGREGEX = "^(?P<pver>\d+(\.\d+)+)$" |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit cmake python3native |
| 18 | |
| 19 | EXTRA_OECMAKE = " \ |
| 20 | -DCMAKE_BUILD_TYPE=Release \ |
| 21 | -DBUILD_SHARED_LIBS=ON \ |
| 22 | -DENABLE_PCH=OFF \ |
| 23 | -DENABLE_CTEST=OFF \ |
| 24 | -DBUILD_EXTERNAL=OFF \ |
| 25 | " |
| 26 | |
| 27 | SOLIBSDEV = "glslang.so" |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 28 | # all the other libraries are unversioned, so pack it on PN |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 29 | FILES_${PN} += "${libdir}/*.so" |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |