Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 1 | SUMMARY = "Library for building powerful interactive command lines in Python" |
| 2 | HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f" |
| 5 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 6 | SRC_URI[md5sum] = "f1b34c688ef7dccccb951130f008f6fe" |
| 7 | SRC_URI[sha256sum] = "822f4605f28f7d2ba6b0b09a31e25e140871e96364d1d377667b547bb3bf4489" |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 8 | |
| 9 | inherit pypi setuptools3 |
| 10 | |
| 11 | PYPI_PACKAGE = "prompt_toolkit" |
| 12 | |
| 13 | RDEPENDS_${PN} += " \ |
| 14 | ${PYTHON_PN}-core \ |
| 15 | ${PYTHON_PN}-six \ |
| 16 | ${PYTHON_PN}-terminal \ |
| 17 | ${PYTHON_PN}-threading \ |
| 18 | ${PYTHON_PN}-wcwidth \ |
| 19 | ${PYTHON_PN}-datetime \ |
| 20 | ${PYTHON_PN}-shell \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 21 | ${PYTHON_PN}-image \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 22 | " |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |