Joel Stanley | 7259c7d | 2019-11-04 23:43:51 +1030 | [diff] [blame] | 1 | SUMMARY = "eCMD" |
| 2 | DESCRIPTION = "eCMD is a hardware access API for IBM Systems" |
| 3 | LICENSE= "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${S}/NOTICE;md5=fee220301a2af3faf8f211524b4248ea" |
| 5 | |
| 6 | SRC_URI = "git://github.com/open-power/eCMD.git" |
Joel Stanley | ac6d51c | 2020-01-03 13:53:18 +1100 | [diff] [blame^] | 7 | SRCREV = "b858b2f212bda2665ad41e821302e8196c7aec07" |
Joel Stanley | 7259c7d | 2019-11-04 23:43:51 +1030 | [diff] [blame] | 8 | DEPENDS += "python-native zlib" |
| 9 | |
Joel Stanley | 5f2105b | 2019-11-05 11:25:16 +1030 | [diff] [blame] | 10 | SRC_URI += "file://croserver.service" |
| 11 | |
Joel Stanley | 7259c7d | 2019-11-04 23:43:51 +1030 | [diff] [blame] | 12 | S = "${WORKDIR}/git" |
| 13 | |
Joel Stanley | 7259c7d | 2019-11-04 23:43:51 +1030 | [diff] [blame] | 14 | do_configure() { |
Joel Stanley | ac6d51c | 2020-01-03 13:53:18 +1100 | [diff] [blame^] | 15 | LD="${CXX}" ${S}/config.py --without-swig --output-root ${B} --target obj --extensions "cmd cip" --build-verbose |
Joel Stanley | 7259c7d | 2019-11-04 23:43:51 +1030 | [diff] [blame] | 16 | } |
| 17 | |
| 18 | do_compile() { |
| 19 | cd ${S}/dllNetwork/server |
| 20 | oe_runmake |
| 21 | } |
| 22 | |
| 23 | do_install() { |
| 24 | install -d ${D}${bindir} |
| 25 | install -m 0755 out_obj/lib/server1p ${D}${bindir}/croserver |
Joel Stanley | 5f2105b | 2019-11-05 11:25:16 +1030 | [diff] [blame] | 26 | |
| 27 | install -d ${D}${systemd_system_unitdir} |
| 28 | install -m 0644 ${WORKDIR}/croserver.service ${D}${systemd_system_unitdir}/ |
Joel Stanley | 7259c7d | 2019-11-04 23:43:51 +1030 | [diff] [blame] | 29 | } |
Joel Stanley | 5f2105b | 2019-11-05 11:25:16 +1030 | [diff] [blame] | 30 | |
| 31 | FILES_${PN} += "${systemd_system_unitdir}/croserver.service" |