blob: 17d0c032f73f58954f21670fe61c9bf44a11acba [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The Python Programming Language"
2HOMEPAGE = "http://www.python.org"
3LICENSE = "PSFv2"
4SECTION = "devel/python"
5
Andrew Geissler6ce62a22020-11-30 19:58:47 -06006LIC_FILES_CHKSUM = "file://LICENSE;md5=33223c9ef60c31e3f0e866cb09b65e83"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
8SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
9 file://run-ptest \
10 file://create_manifest3.py \
11 file://get_module_deps3.py \
12 file://python3-manifest.json \
13 file://check_build_completeness.py \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060014 file://reformat_sysconfig.py \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 file://cgi_py.patch \
16 file://0001-Do-not-add-usr-lib-termcap-to-linker-flags-to-avoid-.patch \
17 ${@bb.utils.contains('PACKAGECONFIG', 'tk', '', 'file://avoid_warning_about_tkinter.patch', d)} \
18 file://0001-Do-not-use-the-shell-version-of-python-config-that-w.patch \
19 file://python-config.patch \
20 file://0001-Makefile.pre-use-qemu-wrapper-when-gathering-profile.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050021 file://0001-python3-use-cc_basename-to-replace-CC-for-checking-c.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050022 file://0001-Makefile-fix-Issue36464-parallel-build-race-problem.patch \
23 file://0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch \
24 file://crosspythonpath.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050025 file://0001-Use-FLAG_REF-always-for-interned-strings.patch \
26 file://0001-test_locale.py-correct-the-test-output-format.patch \
27 file://0017-setup.py-do-not-report-missing-dependencies-for-disa.patch \
28 file://0001-setup.py-pass-missing-libraries-to-Extension-for-mul.patch \
29 file://0001-Makefile-do-not-compile-.pyc-in-parallel.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050030 file://0020-configure.ac-setup.py-do-not-add-a-curses-include-pa.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060031 file://0001-Lib-sysconfig.py-use-libdir-values-from-configuratio.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050032 "
33
34SRC_URI_append_class-native = " \
35 file://0001-distutils-sysconfig-append-STAGING_LIBDIR-python-sys.patch \
36 file://12-distutils-prefix-is-inside-staging-area.patch \
37 file://0001-Don-t-search-system-for-headers-libraries.patch \
38 "
Andrew Geisslerc723b722021-01-08 16:14:09 -060039SRC_URI[sha256sum] = "991c3f8ac97992f3d308fefeb03a64db462574eadbff34ce8bc5bb583d9903ff"
Andrew Geissler82c905d2020-04-13 13:39:40 -050040
41# exclude pre-releases for both python 2.x and 3.x
42UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
Andrew Geissler4c19ea12020-10-27 13:52:24 -050043UPSTREAM_CHECK_URI = "https://www.python.org/downloads/source/"
Andrew Geissler82c905d2020-04-13 13:39:40 -050044
45CVE_PRODUCT = "python"
46
Andrew Geissler6ce62a22020-11-30 19:58:47 -060047# Upstream consider this expected behaviour
48CVE_CHECK_WHITELIST += "CVE-2007-4559"
Andrew Geissler82c905d2020-04-13 13:39:40 -050049# This is not exploitable when glibc has CVE-2016-10739 fixed.
50CVE_CHECK_WHITELIST += "CVE-2019-18348"
51
Andrew Geissler6ce62a22020-11-30 19:58:47 -060052# This is windows only issue.
53CVE_CHECK_WHITELIST += "CVE-2020-15523"
54
55PYTHON_MAJMIN = "3.9"
Andrew Geissler82c905d2020-04-13 13:39:40 -050056
57S = "${WORKDIR}/Python-${PV}"
58
59BBCLASSEXTEND = "native nativesdk"
60
61inherit autotools pkgconfig qemu ptest multilib_header update-alternatives
62
63MULTILIB_SUFFIX = "${@d.getVar('base_libdir',1).split('/')[-1]}"
64
65ALTERNATIVE_${PN}-dev = "python3-config"
66ALTERNATIVE_LINK_NAME[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config"
67ALTERNATIVE_TARGET[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}"
68
69
70DEPENDS = "bzip2-replacement-native libffi bzip2 openssl sqlite3 zlib virtual/libintl xz virtual/crypt util-linux libtirpc libnsl2"
71DEPENDS_append_class-target = " python3-native"
72DEPENDS_append_class-nativesdk = " python3-native"
73
Andrew Geissler6ce62a22020-11-30 19:58:47 -060074EXTRA_OECONF = " --without-ensurepip --enable-shared --with-platlibdir=${baselib}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050075EXTRA_OECONF_append_class-native = " --bindir=${bindir}/${PN}"
76
77export CROSSPYTHONPATH="${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/"
78
79EXTRANATIVEPATH += "python3-native"
80
Andrew Geissler6ce62a22020-11-30 19:58:47 -060081# LTO will be enabled via packageconfig depending upong distro features
82LTO_class-target = ""
83
Andrew Geissler82c905d2020-04-13 13:39:40 -050084CACHED_CONFIGUREVARS = " \
85 ac_cv_file__dev_ptmx=yes \
86 ac_cv_file__dev_ptc=no \
87 ac_cv_working_tzset=yes \
88"
Andrew Geisslerd25ed322020-06-27 00:28:28 -050089
90def possibly_include_pgo(d):
Andrew Geissler82c905d2020-04-13 13:39:40 -050091 # PGO currently causes builds to not be reproducible, so disable it for
92 # now. See YOCTO #13407
93 if bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d) and d.getVar('BUILD_REPRODUCIBLE_BINARIES') != '1':
Andrew Geisslerd25ed322020-06-27 00:28:28 -050094 return 'pgo'
95
96 return ''
Andrew Geissler82c905d2020-04-13 13:39:40 -050097
Andrew Geissler6ce62a22020-11-30 19:58:47 -060098PACKAGECONFIG_class-target ??= "readline ${@possibly_include_pgo(d)} gdbm ${@bb.utils.filter('DISTRO_FEATURES', 'lto', d)}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050099PACKAGECONFIG_class-native ??= "readline gdbm"
100PACKAGECONFIG_class-nativesdk ??= "readline gdbm"
101PACKAGECONFIG[readline] = ",,readline"
102# Use profile guided optimisation by running PyBench inside qemu-user
103PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
104PACKAGECONFIG[tk] = ",,tk"
105PACKAGECONFIG[gdbm] = ",,gdbm"
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600106PACKAGECONFIG[lto] = "--with-lto,,"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500107
108do_configure_prepend () {
109 mkdir -p ${B}/Modules
110 cat > ${B}/Modules/Setup.local << EOF
111*disabled*
112${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '', '_gdbm _dbm', d)}
113${@bb.utils.contains('PACKAGECONFIG', 'readline', '', 'readline', d)}
114EOF
115}
116
117CPPFLAGS_append = " -I${STAGING_INCDIR}/ncursesw -I${STAGING_INCDIR}/uuid"
118
119EXTRA_OEMAKE = '\
120 STAGING_LIBDIR=${STAGING_LIBDIR} \
121 STAGING_INCDIR=${STAGING_INCDIR} \
122 LIB=${baselib} \
123'
124
125do_compile_prepend_class-target() {
126 if ${@bb.utils.contains('PACKAGECONFIG', 'pgo', 'true', 'false', d)}; then
127 qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}', ['${B}', '${STAGING_DIR_TARGET}/${base_libdir}'])}"
128 cat >pgo-wrapper <<EOF
129#!/bin/sh
130cd ${B}
131$qemu_binary "\$@"
132EOF
133 chmod +x pgo-wrapper
134 fi
135}
136
137do_install_prepend() {
138 ${WORKDIR}/check_build_completeness.py ${T}/log.do_compile
139}
140
141do_install_append_class-target() {
142 oe_multilib_header python${PYTHON_MAJMIN}/pyconfig.h
143}
144
145do_install_append_class-native() {
146 # Make sure we use /usr/bin/env python
147 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
148 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
149 done
150 # Add a symlink to the native Python so that scripts can just invoke
151 # "nativepython" and get the right one without needing absolute paths
152 # (these often end up too long for the #! parser in the kernel as the
153 # buffer is 128 bytes long).
154 ln -s python3-native/python3 ${D}${bindir}/nativepython3
155}
156
157do_install_append() {
158 mkdir -p ${D}${libdir}/python-sysconfigdata
159 sysconfigfile=`find ${D} -name _sysconfig*.py`
160 cp $sysconfigfile ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
161
162 sed -i \
163 -e "s,^ 'LIBDIR'.*, 'LIBDIR': '${STAGING_LIBDIR}'\,,g" \
164 -e "s,^ 'INCLUDEDIR'.*, 'INCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
165 -e "s,^ 'CONFINCLUDEDIR'.*, 'CONFINCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
166 -e "/^ 'INCLDIRSTOMAKE'/{N; s,/usr/include,${STAGING_INCDIR},g}" \
167 -e "/^ 'INCLUDEPY'/s,/usr/include,${STAGING_INCDIR},g" \
168 ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600169
170 # Unfortunately the following pyc files are non-deterministc due to 'frozenset'
171 # being written without strict ordering, even with PYTHONHASHSEED = 0
172 # Upstream is discussing ways to solve the issue properly, until then let's
173 # just not install the problematic files.
174 # More info: http://benno.id.au/blog/2013/01/15/python-determinism
175 rm ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_range.cpython*
176 rm ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_xml_etree.cpython*
Andrew Geissler82c905d2020-04-13 13:39:40 -0500177}
178
179do_install_append_class-nativesdk () {
180 create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1'
181}
182
183SSTATE_SCAN_FILES += "Makefile _sysconfigdata.py"
184PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
185
186py_package_preprocess () {
187 # Remove references to buildmachine paths in target Makefile and _sysconfigdata
188 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
189 -e 's|${DEBUG_PREFIX_MAP}||g' \
190 -e 's:${HOSTTOOLS_DIR}/::g' \
191 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
192 -e 's:${RECIPE_SYSROOT}::g' \
193 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
194 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile \
195 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py \
196 ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config
197
198 # Reformat _sysconfigdata after modifying it so that it remains
199 # reproducible
200 for c in ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
201 python3 ${WORKDIR}/reformat_sysconfig.py $c
202 done
203
204 # Recompile _sysconfigdata after modifying it
205 cd ${PKGD}
206 sysconfigfile=`find . -name _sysconfigdata_*.py`
207 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
208 -c "from py_compile import compile; compile('$sysconfigfile')"
209 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
210 -c "from py_compile import compile; compile('$sysconfigfile', optimize=1)"
211 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
212 -c "from py_compile import compile; compile('$sysconfigfile', optimize=2)"
213 cd -
214
215 mv ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}
216
217 #Remove the unneeded copy of target sysconfig data
218 rm -rf ${PKGD}/${libdir}/python-sysconfigdata
219}
220
221# We want bytecode precompiled .py files (.pyc's) by default
222# but the user may set it on their own conf
223INCLUDE_PYCS ?= "1"
224
225python(){
226 import collections, json
227
228 filename = os.path.join(d.getVar('THISDIR'), 'python3', 'python3-manifest.json')
229 # This python changes the datastore based on the contents of a file, so mark
230 # that dependency.
231 bb.parse.mark_dependency(d, filename)
232
233 with open(filename) as manifest_file:
234 manifest_str = manifest_file.read()
235 json_start = manifest_str.find('# EOC') + 6
236 manifest_file.seek(json_start)
237 manifest_str = manifest_file.read()
238 python_manifest = json.loads(manifest_str, object_pairs_hook=collections.OrderedDict)
239
240 # First set RPROVIDES for -native case
241 # Hardcoded since it cant be python3-native-foo, should be python3-foo-native
242 pn = 'python3'
243 rprovides = d.getVar('RPROVIDES').split()
244
245 # ${PN}-misc-native is not in the manifest
246 rprovides.append(pn + '-misc-native')
247
248 for key in python_manifest:
249 pypackage = pn + '-' + key + '-native'
250 if pypackage not in rprovides:
251 rprovides.append(pypackage)
252
253 d.setVar('RPROVIDES_class-native', ' '.join(rprovides))
254
255 # Then work on the target
256 include_pycs = d.getVar('INCLUDE_PYCS')
257
258 packages = d.getVar('PACKAGES').split()
259 pn = d.getVar('PN')
260
261 newpackages=[]
262 for key in python_manifest:
263 pypackage = pn + '-' + key
264
265 if pypackage not in packages:
266 # We need to prepend, otherwise python-misc gets everything
267 # so we use a new variable
268 newpackages.append(pypackage)
269
270 # "Build" python's manifest FILES, RDEPENDS and SUMMARY
271 d.setVar('FILES_' + pypackage, '')
272 for value in python_manifest[key]['files']:
273 d.appendVar('FILES_' + pypackage, ' ' + value)
274
275 # Add cached files
276 if include_pycs == '1':
277 for value in python_manifest[key]['cached']:
278 d.appendVar('FILES_' + pypackage, ' ' + value)
279
280 for value in python_manifest[key]['rdepends']:
281 # Make it work with or without $PN
282 if '${PN}' in value:
283 value=value.split('-', 1)[1]
284 d.appendVar('RDEPENDS_' + pypackage, ' ' + pn + '-' + value)
285
286 for value in python_manifest[key].get('rrecommends', ()):
287 if '${PN}' in value:
288 value=value.split('-', 1)[1]
289 d.appendVar('RRECOMMENDS_' + pypackage, ' ' + pn + '-' + value)
290
291 d.setVar('SUMMARY_' + pypackage, python_manifest[key]['summary'])
292
293 # Prepending so to avoid python-misc getting everything
294 packages = newpackages + packages
295 d.setVar('PACKAGES', ' '.join(packages))
296 d.setVar('ALLOW_EMPTY_${PN}-modules', '1')
297 d.setVar('ALLOW_EMPTY_${PN}-pkgutil', '1')
298}
299
300# Files needed to create a new manifest
301
302do_create_manifest() {
303 # This task should be run with every new release of Python.
304 # We must ensure that PACKAGECONFIG enables everything when creating
305 # a new manifest, this is to base our new manifest on a complete
306 # native python build, containing all dependencies, otherwise the task
307 # wont be able to find the required files.
308 # e.g. BerkeleyDB is an optional build dependency so it may or may not
309 # be present, we must ensure it is.
310
311 cd ${WORKDIR}
312 # This needs to be executed by python-native and NOT by HOST's python
313 nativepython3 create_manifest3.py ${PYTHON_MAJMIN}
314 cp python3-manifest.json.new ${THISDIR}/python3/python3-manifest.json
315}
316
317# bitbake python -c create_manifest
318addtask do_create_manifest
319
320# Make sure we have native python ready when we create a new manifest
321do_create_manifest[depends] += "${PN}:do_prepare_recipe_sysroot"
322do_create_manifest[depends] += "${PN}:do_patch"
323
324# manual dependency additions
325RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python3-modules"
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500326RRECOMMENDS_${PN}-crypt_append_class-target = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
327RRECOMMENDS_${PN}-crypt_append_class-nativesdk = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500328
329# For historical reasons PN is empty and provided by python3-modules
330FILES_${PN} = ""
331RPROVIDES_${PN}-modules = "${PN}"
332
333FILES_${PN}-pydoc += "${bindir}/pydoc${PYTHON_MAJMIN} ${bindir}/pydoc3"
334FILES_${PN}-idle += "${bindir}/idle3 ${bindir}/idle${PYTHON_MAJMIN}"
335
336# provide python-pyvenv from python3-venv
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500337RPROVIDES_${PN}-venv += "${MLPREFIX}python3-pyvenv"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500338
339# package libpython3
340PACKAGES =+ "libpython3 libpython3-staticdev"
341FILES_libpython3 = "${libdir}/libpython*.so.*"
342FILES_libpython3-staticdev += "${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}-*/libpython${PYTHON_MAJMIN}.a"
343INSANE_SKIP_${PN}-dev += "dev-elf"
344
345# catch all the rest (unsorted)
346PACKAGES += "${PN}-misc"
Andrew Geisslerd25ed322020-06-27 00:28:28 -0500347RDEPENDS_${PN}-misc += "\
348 ${PN}-core \
349 ${PN}-email \
350 ${PN}-codecs \
351 ${PN}-pydoc \
352 ${PN}-pickle \
353 ${PN}-audio \
354 ${PN}-numbers \
355"
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500356RDEPENDS_${PN}-modules_append_class-target = " ${MLPREFIX}python3-misc"
357RDEPENDS_${PN}-modules_append_class-nativesdk = " ${MLPREFIX}python3-misc"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500358FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN} ${libdir}/python${PYTHON_MAJMIN}/lib-dynload"
359
360# catch manpage
361PACKAGES += "${PN}-man"
362FILES_${PN}-man = "${datadir}/man"
363
364# See https://bugs.python.org/issue18748 and https://bugs.python.org/issue37395
365RDEPENDS_libpython3_append_libc-glibc = " libgcc"
Andrew Geissler475cb722020-07-10 16:00:51 -0500366RDEPENDS_${PN}-ctypes_append_libc-glibc = " ${MLPREFIX}ldconfig"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500367RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests unzip bzip2 libgcc tzdata-europe coreutils sed"
368RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-tr-tr.iso-8859-9"
369RDEPENDS_${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', 'tk tk-lib', '', d)}"
Andrew Geisslerd25ed322020-06-27 00:28:28 -0500370RDEPENDS_${PN}-idle += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${PN}-tkinter tcl', '', d)}"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500371RDEPENDS_${PN}-dev = ""
372
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500373RDEPENDS_${PN}-tests_append_class-target = " ${MLPREFIX}bash"
374RDEPENDS_${PN}-tests_append_class-nativesdk = " ${MLPREFIX}bash"