Brad Bishop | 3077a7f | 2017-01-12 21:44:51 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenBMC - Applications" |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 2 | PR = "r1" |
| 3 | |
| 4 | inherit packagegroup |
| 5 | inherit obmc-phosphor-utils |
| 6 | inherit obmc-phosphor-license |
| 7 | |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 8 | PROVIDES = "${PACKAGES}" |
| 9 | PACKAGES = " \ |
Brad Bishop | db32a7c | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 10 | ${PN}-bmc-state-mgmt \ |
| 11 | ${PN}-chassis-state-mgmt \ |
Brad Bishop | a242937 | 2016-09-06 22:44:21 -0400 | [diff] [blame] | 12 | ${PN}-extras \ |
| 13 | ${PN}-extrasdev \ |
Brad Bishop | 4824d4c | 2017-05-01 11:54:34 -0400 | [diff] [blame] | 14 | ${PN}-fan-control \ |
Brad Bishop | db32a7c | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 15 | ${PN}-host-state-mgmt \ |
Brad Bishop | 4f12f72 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 16 | ${PN}-inventory \ |
| 17 | ${PN}-leds \ |
| 18 | ${PN}-sensors \ |
Gunnar Mills | 058788a | 2017-02-15 16:01:45 -0600 | [diff] [blame] | 19 | ${PN}-software \ |
Andrew Geissler | b1afecc | 2017-05-08 15:58:01 -0500 | [diff] [blame] | 20 | ${PN}-host-check-mgmt \ |
Jayanth Othayoth | 9be81b1 | 2017-05-08 09:25:05 -0500 | [diff] [blame] | 21 | ${PN}-debug-collector \ |
Deepak Kodihalli | feb8867 | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 22 | ${PN}-settings \ |
Ratan Gupta | d3c6164 | 2017-07-06 21:09:14 +0530 | [diff] [blame] | 23 | ${PN}-network \ |
Vishwanatha Subbanna | 0ea6f63 | 2017-10-18 15:47:54 +0530 | [diff] [blame] | 24 | ${PN}-user-mgmt \ |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 25 | " |
| 26 | |
Brad Bishop | db32a7c | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 27 | SUMMARY_${PN}-bmc-state-mgmt = "BMC state management" |
| 28 | RDEPENDS_${PN}-bmc-state-mgmt = " \ |
| 29 | ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \ |
| 30 | " |
| 31 | |
| 32 | SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management" |
| 33 | RDEPENDS_${PN}-chassis-state-mgmt = " \ |
| 34 | ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \ |
| 35 | " |
| 36 | |
Andrew Geissler | b1afecc | 2017-05-08 15:58:01 -0500 | [diff] [blame] | 37 | SUMMARY_${PN}-host-check-mgmt = "Host state check on bmc reset" |
| 38 | RDEPENDS_${PN}-host-check-mgmt = " \ |
| 39 | ${VIRTUAL-RUNTIME_obmc-host-check} \ |
| 40 | " |
| 41 | |
Brad Bishop | a242937 | 2016-09-06 22:44:21 -0400 | [diff] [blame] | 42 | SUMMARY_${PN}-extras = "Extra features" |
| 43 | RDEPENDS_${PN}-extras = " \ |
Brad Bishop | 3077a7f | 2017-01-12 21:44:51 -0500 | [diff] [blame] | 44 | phosphor-rest \ |
Brad Bishop | 0f547b1 | 2017-05-31 14:08:33 -0400 | [diff] [blame] | 45 | phosphor-dbus-monitor \ |
Brad Bishop | 70436da | 2015-09-16 14:49:27 -0400 | [diff] [blame] | 46 | " |
| 47 | |
Brad Bishop | a242937 | 2016-09-06 22:44:21 -0400 | [diff] [blame] | 48 | SUMMARY_${PN}-extrasdev = "Development features" |
| 49 | RDEPENDS_${PN}-extrasdev = " \ |
Adriana Kobylak | a3e925f | 2016-06-16 14:46:06 -0500 | [diff] [blame] | 50 | rest-dbus \ |
| 51 | " |
Brad Bishop | 4f12f72 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 52 | |
Brad Bishop | 4824d4c | 2017-05-01 11:54:34 -0400 | [diff] [blame] | 53 | # Use the fan control package group for applications |
| 54 | # implementing fan control or system fan policy only. |
| 55 | # Applications that create inventory or sensors should |
| 56 | # be added those respective package groups instead. |
| 57 | SUMMARY_${PN}-fan-control = "Fan control" |
| 58 | RDEPENDS_${PN}-fan-control = " \ |
Matt Spinler | c133ec1 | 2017-04-19 08:23:50 -0500 | [diff] [blame] | 59 | ${VIRTUAL-RUNTIME_obmc-fan-control} \ |
Matt Spinler | dd7a080 | 2017-05-01 14:29:20 -0500 | [diff] [blame] | 60 | phosphor-fan-monitor \ |
Brad Bishop | 4824d4c | 2017-05-01 11:54:34 -0400 | [diff] [blame] | 61 | " |
| 62 | |
Brad Bishop | db32a7c | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 63 | SUMMARY_${PN}-host-state-mgmt = "Host state management" |
| 64 | RDEPENDS_${PN}-host-state-mgmt = " \ |
| 65 | ${VIRTUAL-RUNTIME_obmc-host-state-manager} \ |
Michael Tritz | b3b5899 | 2017-03-31 12:04:32 -0500 | [diff] [blame] | 66 | ${VIRTUAL-RUNTIME_obmc-discover-system-state} \ |
Brad Bishop | db32a7c | 2017-03-01 16:16:06 -0500 | [diff] [blame] | 67 | " |
| 68 | |
Brad Bishop | 4f12f72 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 69 | SUMMARY_${PN}-inventory = "Inventory applications" |
| 70 | RDEPENDS_${PN}-inventory = " \ |
| 71 | ${VIRTUAL-RUNTIME_obmc-inventory-manager} \ |
Matthew Barth | acd9fe4 | 2017-02-24 13:14:43 -0600 | [diff] [blame] | 72 | ${VIRTUAL-RUNTIME_obmc-fan-presence} \ |
Brad Bishop | 4f12f72 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 73 | " |
| 74 | |
| 75 | SUMMARY_${PN}-leds = "LED applications" |
| 76 | RDEPENDS_${PN}-leds = " \ |
Brad Bishop | af7d060 | 2017-02-27 11:59:49 -0500 | [diff] [blame] | 77 | ${VIRTUAL-RUNTIME_obmc-leds-manager} \ |
| 78 | ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \ |
Dhruvaraj Subhashchandran | 6a1b0fc | 2017-04-27 05:29:56 -0500 | [diff] [blame] | 79 | ${VIRTUAL-RUNTIME_obmc-led-monitor} \ |
Brad Bishop | 4f12f72 | 2017-02-01 21:04:14 -0500 | [diff] [blame] | 80 | " |
| 81 | |
| 82 | SUMMARY_${PN}-sensors = "Sensor applications" |
| 83 | RDEPENDS_${PN}-sensors = " \ |
| 84 | ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \ |
| 85 | " |
Gunnar Mills | 058788a | 2017-02-15 16:01:45 -0600 | [diff] [blame] | 86 | |
| 87 | SUMMARY_${PN}-software = "Software applications" |
| 88 | RDEPENDS_${PN}-software = " \ |
Deepak Kodihalli | b74ceea | 2017-04-13 23:23:42 -0500 | [diff] [blame] | 89 | ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \ |
Gunnar Mills | cfe0084 | 2017-05-15 15:40:58 -0500 | [diff] [blame] | 90 | ${VIRTUAL-RUNTIME_obmc-bmc-updater} \ |
Gunnar Mills | 058788a | 2017-02-15 16:01:45 -0600 | [diff] [blame] | 91 | " |
Jayanth Othayoth | 9be81b1 | 2017-05-08 09:25:05 -0500 | [diff] [blame] | 92 | SUMMARY_${PN}-debug-collector = "BMC debug collector" |
| 93 | RDEPENDS_${PN}-debug-collector = " \ |
Jayanth Othayoth | 2a5d91e | 2017-05-31 06:25:55 -0500 | [diff] [blame] | 94 | ${VIRTUAL-RUNTIME_obmc-dump-manager} \ |
| 95 | ${VIRTUAL-RUNTIME_obmc-dump-monitor} \ |
Jayanth Othayoth | f4e6607 | 2017-07-29 22:28:44 -0500 | [diff] [blame] | 96 | phosphor-debug-collector-dreport \ |
Marri Devender Rao | b6e5cb0 | 2017-10-11 02:22:46 -0500 | [diff] [blame^] | 97 | phosphor-debug-collector-scripts \ |
Vishwanatha Subbanna | dfd5bf3 | 2017-05-12 23:31:55 +0530 | [diff] [blame] | 98 | " |
Deepak Kodihalli | feb8867 | 2017-05-17 06:42:51 -0500 | [diff] [blame] | 99 | |
| 100 | SUMMARY_${PN}-settings = "Settings applications" |
| 101 | RDEPENDS_${PN}-settings = " \ |
| 102 | ${VIRTUAL-RUNTIME_obmc-settings-mgr} \ |
| 103 | " |
Ratan Gupta | d3c6164 | 2017-07-06 21:09:14 +0530 | [diff] [blame] | 104 | |
| 105 | SUMMARY_${PN}-network = "BMC Network Manager" |
| 106 | RDEPENDS_${PN}-network = " \ |
| 107 | ${VIRTUAL-RUNTIME_obmc-network-manager} \ |
| 108 | " |
Vishwanatha Subbanna | 0ea6f63 | 2017-10-18 15:47:54 +0530 | [diff] [blame] | 109 | |
| 110 | SUMMARY_${PN}-user-mgmt = "User management applications" |
| 111 | RDEPENDS_${PN}-user-mgmt = " \ |
| 112 | ${VIRTUAL-RUNTIME_obmc-user-mgmt} \ |
| 113 | " |