Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Precision Time Protocol (PTP) according to IEEE standard 1588 for Linux" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | |
| 5 | SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz \ |
| 6 | file://build-Allow-CC-and-prefix-to-be-overriden.patch \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 7 | file://Use-cross-cpp-in-incdefs.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | " |
| 9 | |
Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame^] | 10 | SRC_URI[md5sum] = "2264cb69c9af947028835c12c89a7572" |
| 11 | SRC_URI[sha256sum] = "f58f5b11cf14dc7c4f7c9efdfb27190e43d02cf20c3525f6639edac10528ce7d" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 13 | EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} EXTRA_CFLAGS='${CFLAGS}'" |
| 14 | |
| 15 | export KBUILD_OUTPUT="${RECIPE_SYSROOT}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 16 | |
| 17 | do_install () { |
| 18 | install -d ${D}/${bindir} |
| 19 | install -p ${S}/ptp4l ${D}/${bindir} |
| 20 | install -p ${S}/pmc ${D}/${bindir} |
| 21 | install -p ${S}/phc2sys ${D}/${bindir} |
| 22 | install -p ${S}/hwstamp_ctl ${D}/${bindir} |
| 23 | } |