Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "1-Wire file system" |
| 2 | DESCRIPTION = "OWFS is an easy way to use the powerful 1-wire system of Dallas/Maxim" |
| 3 | HOMEPAGE = "http://www.owfs.org/" |
| 4 | SECTION = "console/network" |
| 5 | |
| 6 | LICENSE = "GPLv2 & LGPLv2" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=628b867016631792781a8735a04760e5 \ |
| 8 | file://COPYING.LIB;md5=9021b7435efdd9fb22beef8291134099" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 9 | |
| 10 | DEPENDS = "fuse virtual/libusb0" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 11 | # v3.2p3 |
| 12 | SRCREV = "3744375dfaa350e31c9b360eb1e1a517bbeb5c47" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | SRC_URI = "git://github.com/owfs/owfs \ |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 14 | file://0001-Add-build-rule-for-README.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | file://owhttpd \ |
| 16 | file://owserver \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | " |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | inherit autotools-brokensep update-rc.d pkgconfig systemd |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 22 | |
| 23 | EXTRA_OECONF = " \ |
| 24 | --with-fuseinclude=${STAGING_INCDIR} \ |
| 25 | --with-fuselib=${STAGING_LIBDIR} \ |
| 26 | --enable-owfs \ |
| 27 | --enable-owhttpd \ |
| 28 | --enable-w1 \ |
| 29 | --disable-swig \ |
| 30 | --disable-owtcl \ |
| 31 | --disable-owphp \ |
| 32 | --disable-owpython \ |
| 33 | --disable-owperl \ |
| 34 | " |
| 35 | |
| 36 | do_install_prepend() { |
| 37 | install -d ${D}${sysconfdir}/default/ |
| 38 | install -d ${D}${sysconfdir}/init.d/ |
| 39 | install -m 0755 ${WORKDIR}/owhttpd ${D}${sysconfdir}/init.d/owhttpd |
| 40 | install -m 0755 ${WORKDIR}/owserver ${D}${sysconfdir}/init.d/owserver |
| 41 | } |
| 42 | |
| 43 | PACKAGES =+ "owftpd owhttpd owserver owshell libowcapi libow libownet owmon owtap" |
| 44 | |
| 45 | DESCRIPTION_owftpd = "Anoymous FTP server for 1-wire access" |
| 46 | DESCRIPTION_owhttpd = "Tiny webserver for 1-wire control" |
| 47 | DESCRIPTION_owserver = "Backend server (daemon) for 1-wire control" |
| 48 | DESCRIPTION_owshell = "owdir owread owwrite owpresent owget - lightweight owserver access" |
| 49 | DESCRIPTION_libowcapi = "easy C-language 1-wire interface " |
| 50 | DESCRIPTION_libow = "easy C-language 1-wire interface to the owserver protocol" |
| 51 | DESCRIPTION_libownet = "easy C-language 1-wire interface to the owserver protocol" |
| 52 | DESCRIPTION_owmon = "Monitor for owserver settings and statistics" |
| 53 | DESCRIPTION_owtap = "Packet sniffer for the owserver protocol" |
| 54 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 55 | FILES_owftpd = "${bindir}/owftpd ${systemd_system_unitdir}/owftpd.service" |
| 56 | FILES_owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd \ |
| 57 | ${systemd_system_unitdir}/owhttpd.service" |
| 58 | FILES_owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver \ |
| 59 | ${systemd_system_unitdir}/owserver.service \ |
| 60 | ${systemd_system_unitdir}/owserver.socket" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 61 | FILES_owshell = "${bindir}/owread ${bindir}/owwrite \ |
| 62 | ${bindir}/owdir ${bindir}/owpresent \ |
| 63 | ${bindir}/owget ${bindir}/owside" |
| 64 | FILES_owmon = "${bindir}/owmon" |
| 65 | FILES_owtap = "${bindir}/owtap" |
| 66 | FILES_libowcapi = "${libdir}/libowcapi-*" |
| 67 | FILES_libow = "${libdir}/libow-*" |
| 68 | FILES_libownet = "${libdir}/libownet-*" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 69 | FILES_${PN} += "${systemd_system_unitdir}/owfs.service" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 70 | |
| 71 | INITSCRIPT_PACKAGES = "owhttpd owserver" |
| 72 | INITSCRIPT_NAME_owserver = "owserver" |
| 73 | INITSCRIPT_NAME_owhttpd = "owhttpd" |
| 74 | INITSCRIPT_PARAMS_owserver = "defaults 20" |
| 75 | INITSCRIPT_PARAMS_owhttpd = "defaults 21" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 76 | |
| 77 | SYSTEMD_SERVICE_${PN} = "owfs.service" |
| 78 | SYSTEMD_SERVICE_${PN}-owftpd = "owftpd.service" |
| 79 | SYSTEMD_SERVICE_${PN}-owhttpd = "owhttpd.service" |
| 80 | SYSTEMD_SERVICE_${PN}-owserver = "owserver.service owserver.socket" |