blob: 6273ee2f204ea299db27be86625d4722b12e8d95 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "matplotlib: plotting with Python"
2DESCRIPTION = "\
3Matplotlib is a Python 2D plotting library which produces \
4publication-quality figures in a variety of hardcopy formats \
5and interactive environments across platforms."
6HOMEPAGE = "https://github.com/matplotlib/matplotlib"
7SECTION = "devel/python"
8LICENSE = "PSF"
9LIC_FILES_CHKSUM = "\
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050010 file://setup.py;beginline=251;endline=251;md5=e0ef37de7122ce842bcd1fb54482b353 \
Andrew Geissler82c905d2020-04-13 13:39:40 -050011 file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \
12"
13DEPENDS = "\
14 freetype \
15 libpng \
16 python3-numpy-native \
17 python3-dateutil-native \
18 python3-pytz-native \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050019 python3-certifi-native \
Andrew Geissler82c905d2020-04-13 13:39:40 -050020"
21
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050022SRC_URI[md5sum] = "f3a405f340be5b151cb2042c4d8d16f7"
23SRC_URI[sha256sum] = "87f53bcce90772f942c2db56736788b39332d552461a5cb13f05ff45c1680f0e"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25inherit pypi setuptools3 pkgconfig
26
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050027# LTO with clang needs lld
28LDFLAGS_append_toolchain-clang = " -fuse-ld=lld"
29
Andrew Geissler82c905d2020-04-13 13:39:40 -050030RDEPENDS_${PN} = "\
31 freetype \
32 libpng \
33 python3-numpy \
34 python3-pyparsing \
35 python3-cycler \
36 python3-dateutil \
37 python3-kiwisolver \
38 python3-pytz \
39"
40
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050041do_compile_prepend() {
42 echo [libs] > ${S}/setup.cfg
43 echo system_freetype = true >> ${S}/setup.cfg
44}
45
Andrew Geissler82c905d2020-04-13 13:39:40 -050046BBCLASSEXTEND = "native"