blob: 38c012843f1c5b69309d70708146310ba4cf6981 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A libudev binding"
Andrew Geisslereafcbb82020-06-05 17:59:17 -05002
Andrew Geissler82c905d2020-04-13 13:39:40 -05003LICENSE = "LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
5
Andrew Geisslereafcbb82020-06-05 17:59:17 -05006SRC_URI[sha256sum] = "69bb1beb7ac52855b6d1b9fe909eefb0017f38d917cba9939602c6880035b276"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008inherit pypi setuptools3
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10do_configure_prepend() {
11 sed -i "/import pyudev/d" ${S}/setup.py
12 sed -i "s/str(pyudev.__version__)/'${PV}'/g" ${S}/setup.py
13}
14
15RDEPENDS_${PN} = "\
16 ${PYTHON_PN}-ctypes \
17 ${PYTHON_PN}-misc \
18 ${PYTHON_PN}-six \
19 ${PYTHON_PN}-threading \
Andrew Geissler7f40b712020-05-15 14:09:53 -050020 ${PYTHON_PN}-fcntl \
Andrew Geissler82c905d2020-04-13 13:39:40 -050021 libudev \
22"
Andrew Geisslereafcbb82020-06-05 17:59:17 -050023
24BBCLASSEXTEND = "native nativesdk"