blob: 46fdbbcb9fc5db89cd065d68214b426f0c074cf3 [file] [log] [blame]
Andrew Geissler82cfa662020-02-17 15:11:03 -06001SUMMARY = "OpenPOWER processor control services installation"
2PR = "r1"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit allarch
8
9RDEPENDS_${PN} += "op-proc-control"
10RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
11
12ALLOW_EMPTY_${PN} = "1"
13
14pkg_postinst_${PN}() {
Andrew Geissler55bd4492020-03-31 13:43:46 -050015 mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants
Andrew Geissler82cfa662020-02-17 15:11:03 -060016 mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -050017 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
18 mkdir -p $D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires
Andrew Geissler82cfa662020-02-17 15:11:03 -060019
Andrew Geissler55bd4492020-03-31 13:43:46 -050020 LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -060021 TARGET="../op-stop-instructions@.service"
22 ln -s $TARGET $LINK
23
24 LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
25 TARGET="../op-cfam-reset.service"
26 ln -s $TARGET $LINK
Andrew Geissler4e174d12020-02-26 14:11:53 -060027
28 # Only install cfam override if p9 system
29 if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then
30 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
31 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
32 TARGET="../cfam_override@.service"
33 ln -s $TARGET $LINK
34 fi
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -050035
36 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
37 TARGET="../op-continue-mpreboot@.service"
38 ln -s $TARGET $LINK
39
40 LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
41 TARGET="../op-enter-mpreboot@.service"
42 ln -s $TARGET $LINK
Andrew Geissler82cfa662020-02-17 15:11:03 -060043}
44
45pkg_prerm_${PN}() {
Andrew Geissler55bd4492020-03-31 13:43:46 -050046 LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -060047 rm $LINK
48 LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
49 rm $LINK
Andrew Geissler4e174d12020-02-26 14:11:53 -060050 # Only uninstall cfam override if p9 system
51 if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then
52 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
53 rm $LINK
54 fi
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -050055 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
56 rm $LINK
57 LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
58 rm $LINK
Andrew Geissler82cfa662020-02-17 15:11:03 -060059}