Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 1 | SUMMARY = "Startup script and systemd unit file for the Weston Wayland compositor" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 2 | LICENSE = "MIT" |
| 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690" |
| 4 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 5 | SRC_URI = "file://init \ |
| 6 | file://weston.service" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 7 | |
| 8 | S = "${WORKDIR}" |
| 9 | |
| 10 | do_install() { |
| 11 | install -d ${D}/${sysconfdir}/init.d |
| 12 | install -m755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 13 | |
| 14 | install -d ${D}${systemd_system_unitdir} |
| 15 | install -m0644 ${WORKDIR}/weston.service ${D}${systemd_system_unitdir} |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 16 | } |
| 17 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 18 | inherit allarch update-rc.d distro_features_check systemd |
| 19 | |
| 20 | # rdepends on weston which depends on virtual/egl |
| 21 | REQUIRED_DISTRO_FEATURES = "opengl" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | |
| 23 | RDEPENDS_${PN} = "weston kbd" |
| 24 | |
| 25 | INITSCRIPT_NAME = "weston" |
| 26 | INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ." |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame^] | 27 | |
| 28 | SYSTEMD_SERVICE_${PN} = "weston.service" |