Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Commented config.txt file for the Raspberry Pi. \ |
| 2 | The Raspberry Pi config.txt file is read by the GPU before \ |
| 3 | the ARM core is initialised. It can be used to set various \ |
| 4 | system configuration parameters." |
| 5 | LICENSE = "MIT" |
Brad Bishop | f27bdd5 | 2018-05-07 15:42:31 +0200 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 7 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 8 | COMPATIBLE_MACHINE = "^rpi$" |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 9 | |
| 10 | SRCREV = "648ffc470824c43eb0d16c485f4c24816b32cd6f" |
| 11 | SRC_URI = "git://github.com/Evilpaul/RPi-config.git;protocol=git;branch=master \ |
| 12 | " |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 16 | PR = "r5" |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 17 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 18 | INHIBIT_DEFAULT_DEPS = "1" |
| 19 | |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 20 | PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}" |
| 21 | PITFT22="${@bb.utils.contains("MACHINE_FEATURES", "pitft22", "1", "0", d)}" |
| 22 | PITFT28r="${@bb.utils.contains("MACHINE_FEATURES", "pitft28r", "1", "0", d)}" |
Brad Bishop | 1b9ee29 | 2020-01-16 09:06:00 -0500 | [diff] [blame] | 23 | PITFT28c="${@bb.utils.contains("MACHINE_FEATURES", "pitft28c", "1", "0", d)}" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 24 | PITFT35r="${@bb.utils.contains("MACHINE_FEATURES", "pitft35r", "1", "0", d)}" |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 25 | |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 26 | VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 27 | VC4DTBO ?= "vc4-kms-v3d" |
Andrew Geissler | 4fc9e43 | 2020-06-27 00:13:56 -0500 | [diff] [blame] | 28 | GPIO_IR ?= "18" |
| 29 | GPIO_IR_TX ?= "17" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 30 | |
| 31 | inherit deploy nopackages |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 32 | |
| 33 | do_deploy() { |
| 34 | install -d ${DEPLOYDIR}/bcm2835-bootfiles |
| 35 | |
| 36 | cp ${S}/config.txt ${DEPLOYDIR}/bcm2835-bootfiles/ |
| 37 | |
| 38 | if [ -n "${KEY_DECODE_MPG2}" ]; then |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 39 | sed -i '/#decode_MPG2=/ c\decode_MPG2=${KEY_DECODE_MPG2}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 40 | fi |
| 41 | if [ -n "${KEY_DECODE_WVC1}" ]; then |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 42 | sed -i '/#decode_WVC1=/ c\decode_WVC1=${KEY_DECODE_WVC1}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 43 | fi |
| 44 | if [ -n "${DISABLE_OVERSCAN}" ]; then |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 45 | sed -i '/#disable_overscan=/ c\disable_overscan=${DISABLE_OVERSCAN}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 46 | fi |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 47 | if [ "${DISABLE_SPLASH}" = "1" ]; then |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 48 | sed -i '/#disable_splash=/ c\disable_splash=${DISABLE_SPLASH}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 49 | fi |
| 50 | |
| 51 | # Set overclocking options |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 52 | if [ -n "${ARM_FREQ}" ]; then |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 53 | sed -i '/#arm_freq=/ c\arm_freq=${ARM_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 54 | fi |
| 55 | if [ -n "${GPU_FREQ}" ]; then |
| 56 | sed -i '/#gpu_freq=/ c\gpu_freq=${GPU_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 57 | fi |
| 58 | if [ -n "${CORE_FREQ}" ]; then |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 59 | sed -i '/#core_freq=/ c\core_freq=${CORE_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 60 | fi |
| 61 | if [ -n "${SDRAM_FREQ}" ]; then |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 62 | sed -i '/#sdram_freq=/ c\sdram_freq=${SDRAM_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 63 | fi |
| 64 | if [ -n "${OVER_VOLTAGE}" ]; then |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 65 | sed -i '/#over_voltage=/ c\over_voltage=${OVER_VOLTAGE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 66 | fi |
| 67 | |
| 68 | # GPU memory |
| 69 | if [ -n "${GPU_MEM}" ]; then |
| 70 | sed -i '/#gpu_mem=/ c\gpu_mem=${GPU_MEM}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 71 | fi |
| 72 | if [ -n "${GPU_MEM_256}" ]; then |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 73 | sed -i '/#gpu_mem_256=/ c\gpu_mem_256=${GPU_MEM_256}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 74 | fi |
| 75 | if [ -n "${GPU_MEM_512}" ]; then |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 76 | sed -i '/#gpu_mem_512=/ c\gpu_mem_512=${GPU_MEM_512}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 77 | fi |
| 78 | if [ -n "${GPU_MEM_1024}" ]; then |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 79 | sed -i '/#gpu_mem_1024=/ c\gpu_mem_1024=${GPU_MEM_1024}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 80 | fi |
| 81 | |
| 82 | # Set boot delay |
| 83 | if [ -n "${BOOT_DELAY}" ]; then |
| 84 | sed -i '/#boot_delay=/ c\boot_delay=${BOOT_DELAY}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 85 | fi |
| 86 | if [ -n "${BOOT_DELAY_MS}" ]; then |
| 87 | sed -i '/#boot_delay_ms=/ c\boot_delay_ms=${BOOT_DELAY_MS}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 88 | fi |
| 89 | |
| 90 | # Set HDMI and composite video options |
| 91 | if [ -n "${HDMI_FORCE_HOTPLUG}" ]; then |
| 92 | sed -i '/#hdmi_force_hotplug=/ c\hdmi_force_hotplug=${HDMI_FORCE_HOTPLUG}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 93 | fi |
| 94 | if [ -n "${HDMI_DRIVE}" ]; then |
| 95 | sed -i '/#hdmi_drive=/ c\hdmi_drive=${HDMI_DRIVE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 96 | fi |
| 97 | if [ -n "${HDMI_GROUP}" ]; then |
| 98 | sed -i '/#hdmi_group=/ c\hdmi_group=${HDMI_GROUP}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 99 | fi |
| 100 | if [ -n "${HDMI_MODE}" ]; then |
| 101 | sed -i '/#hdmi_mode=/ c\hdmi_mode=${HDMI_MODE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 102 | fi |
| 103 | if [ -n "${CONFIG_HDMI_BOOST}" ]; then |
| 104 | sed -i '/#config_hdmi_boost=/ c\config_hdmi_boost=${CONFIG_HDMI_BOOST}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 105 | fi |
| 106 | if [ -n "${SDTV_MODE}" ]; then |
| 107 | sed -i '/#sdtv_mode=/ c\sdtv_mode=${SDTV_MODE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 108 | fi |
| 109 | if [ -n "${SDTV_ASPECT}" ]; then |
| 110 | sed -i '/#sdtv_aspect=/ c\sdtv_aspect=${SDTV_ASPECT}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 111 | fi |
| 112 | if [ -n "${DISPLAY_ROTATE}" ]; then |
| 113 | sed -i '/#display_rotate=/ c\display_rotate=${DISPLAY_ROTATE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 114 | fi |
| 115 | |
| 116 | # Video camera support |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 117 | if [ "${VIDEO_CAMERA}" = "1" ]; then |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 118 | echo "# Enable video camera" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 119 | echo "start_x=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 120 | fi |
| 121 | |
| 122 | # Offline compositing support |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 123 | if [ "${DISPMANX_OFFLINE}" = "1" ]; then |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 124 | echo "# Enable offline compositing" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 125 | echo "dispmanx_offline=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 126 | fi |
| 127 | |
| 128 | # SPI bus support |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 129 | if [ "${ENABLE_SPI_BUS}" = "1" ] || [ "${PITFT}" = "1" ]; then |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 130 | echo "# Enable SPI bus" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 131 | echo "dtparam=spi=on" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 132 | fi |
| 133 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 134 | # I2C support |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 135 | if [ "${ENABLE_I2C}" = "1" ] || [ "${PITFT}" = "1" ]; then |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 136 | echo "# Enable I2C" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 137 | echo "dtparam=i2c1=on" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 138 | echo "dtparam=i2c_arm=on" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 139 | fi |
| 140 | |
| 141 | # PiTFT22 display support |
| 142 | if [ "${PITFT22}" = "1" ]; then |
| 143 | echo "# Enable PITFT22 display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 144 | echo "dtoverlay=pitft22,rotate=270,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 145 | fi |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 146 | if [ "${PITFT28r}" = "1" ]; then |
| 147 | echo "# Enable PITFT28r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 148 | echo "dtoverlay=pitft28-resistive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 149 | fi |
Brad Bishop | 1b9ee29 | 2020-01-16 09:06:00 -0500 | [diff] [blame] | 150 | if [ "${PITFT28c}" = "1" ]; then |
| 151 | echo "# Enable PITFT28c display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 152 | echo "dtoverlay=pitft28-capacitive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 153 | echo "dtoverlay=pitft28-capacitive,touch-swapxy,touch-invx" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 154 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 155 | if [ "${PITFT35r}" = "1" ]; then |
| 156 | echo "# Enable PITFT35r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 157 | echo "dtoverlay=pitft35-resistive,rotate=90,speed=42000000,fps=20" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 158 | fi |
| 159 | |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 160 | # UART support |
| 161 | if [ "${ENABLE_UART}" = "1" ]; then |
| 162 | echo "# Enable UART" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 163 | echo "enable_uart=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 164 | fi |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 165 | |
Andrew Geissler | 4fc9e43 | 2020-06-27 00:13:56 -0500 | [diff] [blame] | 166 | # Infrared support |
| 167 | if [ "${ENABLE_IR}" = "1" ]; then |
| 168 | echo "# Enable infrared" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 169 | echo "dtoverlay=gpio-ir,gpio_pin=${GPIO_IR}" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 170 | echo "dtoverlay=gpio-ir-tx,gpio_pin=${GPIO_IR_TX}" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 171 | fi |
| 172 | |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 173 | # VC4 Graphics support |
| 174 | if [ "${VC4GRAPHICS}" = "1" ]; then |
| 175 | echo "# Enable VC4 Graphics" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 176 | echo "dtoverlay=${VC4DTBO}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 177 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 178 | |
| 179 | # Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm) |
| 180 | if [ "${WAVESHARE_1024X600_C_2_1}" = "1" ]; then |
| 181 | echo "# Waveshare \"C\" 1024x600 7\" Rev2.1 IPS capacitive touch screen" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 182 | echo "max_usb_current=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 183 | echo "hdmi_group=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 184 | echo "hdmi_mode=87" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 185 | echo "hdmi_cvt 1024 600 60 6 0 0 0" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 186 | echo "hdmi_drive=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 187 | fi |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 188 | |
| 189 | # DWC2 USB peripheral support |
| 190 | if [ "${ENABLE_DWC2_PERIPHERAL}" = "1" ]; then |
| 191 | echo "# Enable USB peripheral mode" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 192 | echo "dtoverlay=dwc2,dr_mode=peripheral" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 193 | fi |
Brad Bishop | f27bdd5 | 2018-05-07 15:42:31 +0200 | [diff] [blame] | 194 | |
| 195 | # AT86RF23X support |
| 196 | if [ "${ENABLE_AT86RF}" = "1" ]; then |
| 197 | echo "# Enable AT86RF23X" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 198 | echo "dtoverlay=at86rf233,speed=3000000" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 199 | fi |
| 200 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 201 | # ENABLE CAN |
| 202 | if [ "${ENABLE_CAN}" = "1" ]; then |
| 203 | echo "# Enable CAN" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 204 | echo "dtoverlay=mcp2515-can0,oscillator=16000000,interrupt=25" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 205 | fi |
| 206 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 207 | # Append extra config if the user has provided any |
Andrew Geissler | 1c34914 | 2019-02-19 19:49:56 -0600 | [diff] [blame] | 208 | printf "${RPI_EXTRA_CONFIG}\n" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 209 | |
| 210 | # Handle setup with armstub file |
| 211 | if [ "${@bb.utils.contains("MACHINE_FEATURES", "armstub", "1", "0", d)}" = "1" ]; then |
| 212 | echo "\n# ARM stub configuration" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 213 | echo "armstub=${ARMSTUB}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 214 | case "${ARMSTUB}" in |
| 215 | *-gic.bin) |
| 216 | echo "enable_gic=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 217 | ;; |
| 218 | esac |
| 219 | fi |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 220 | } |
| 221 | |
Brad Bishop | 3a5fbf5 | 2017-12-04 02:17:07 -0500 | [diff] [blame] | 222 | do_deploy_append_raspberrypi3-64() { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 223 | echo "# have a properly sized image" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 224 | echo "disable_overscan=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 225 | |
| 226 | echo "# Enable audio (loads snd_bcm2835)" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
| 227 | echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt |
Brad Bishop | 3a5fbf5 | 2017-12-04 02:17:07 -0500 | [diff] [blame] | 228 | } |
| 229 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 230 | addtask deploy before do_build after do_install |
Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 231 | do_deploy[dirs] += "${DEPLOYDIR}/bcm2835-bootfiles" |
| 232 | |
| 233 | PACKAGE_ARCH = "${MACHINE_ARCH}" |