blob: 64dbc758bc17e14f31813ced29e7f6ab6ea608a2 [file] [log] [blame]
Adriana Kobylakb96c7502021-08-06 16:25:30 +00001FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
Matthew Barth035b6162020-01-14 14:21:46 -06002
Adriana Kobylakb96c7502021-08-06 16:25:30 +00003SRC_URI:witherspoon = "file://config.json"
4SRC_URI:p10bmc = "file://rainier-2u/config.json \
Matthew Barth530e1d82020-11-23 19:40:56 -06005 file://rainier-4u/config.json \
Andrew Geisslerdb94adf2021-03-23 18:54:59 -05006 file://rainier-1s4u/config.json \
Matthew Barth530e1d82020-11-23 19:40:56 -06007 file://everest/config.json \
8 "
Matthew Barth035b6162020-01-14 14:21:46 -06009
Adriana Kobylakb96c7502021-08-06 16:25:30 +000010do_install:witherspoon() {
Matthew Barth035b6162020-01-14 14:21:46 -060011 install -d ${D}/${datadir}/phosphor-fan-presence/presence/
12 install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/presence/
13}
Adriana Kobylakb96c7502021-08-06 16:25:30 +000014do_install:p10bmc() {
Matthew Barth530e1d82020-11-23 19:40:56 -060015 # Install Rainier-2U/4U fan presence config files
16 install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
17 install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
Andrew Geisslerdb94adf2021-03-23 18:54:59 -050018 install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/
Matthew Barth530e1d82020-11-23 19:40:56 -060019 install -m 0644 ${WORKDIR}/rainier-2u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
20 install -m 0644 ${WORKDIR}/rainier-4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
Andrew Geisslerdb94adf2021-03-23 18:54:59 -050021 install -m 0644 ${WORKDIR}/rainier-1s4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/
Matthew Barth530e1d82020-11-23 19:40:56 -060022
23 # Install Everest fan presence config file
24 install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
25 install -m 0644 ${WORKDIR}/everest/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
26}
Matthew Barth035b6162020-01-14 14:21:46 -060027
Adriana Kobylakb96c7502021-08-06 16:25:30 +000028FILES:${PN}:append:witherspoon = " ${datadir}/phosphor-fan-presence/presence/config.json"
29FILES:${PN}:remove:witherspoon = "${presence_datadir}/config.yaml"
Matthew Barth530e1d82020-11-23 19:40:56 -060030
Adriana Kobylakb96c7502021-08-06 16:25:30 +000031FILES:${PN}:remove:p10bmc = "${presence_datadir}/config.yaml"
32FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/config.json"
33FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/config.json"
34FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/config.json"
35FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,everest/config.json"