blob: 872872a1106f31a0f12456cc30ac90a3ee6a8215 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "OCI systemd hook enables users to run systemd in docker and OCI"
2SECTION = "console/utils"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
5PRIORITY = "optional"
6
7DEPENDS = "yajl util-linux"
8
9SRCREV = "ca515c1f399bd0b16e94b7c34aa1ef20498beca6"
10SRC_URI = "git://github.com/projectatomic/oci-systemd-hook \
11 file://0001-selinux-drop-selinux-support.patch \
12 file://0001-configure-drop-selinux-support.patch \
13"
14
15PV = "0.0.1+git${SRCPV}"
16S = "${WORKDIR}/git"
17
18inherit autotools pkgconfig
19
20PACKAGECONFIG ??= ""
21PACKAGECONFIG[selinux] = ",,libselinux"
22
23EXTRA_OECONF += "--libexecdir=${libexecdir}/oci/hooks.d"
24
25# nothing to compile, we do it all in the install task
26do_compile[noexec] = "1"
27
28do_install() {
29 # Avoid building docs, and other artifacts by surgically calling the
30 # semi-internal target of "install-exec-am"
31 oe_runmake 'DESTDIR=${D}' install-exec-am
32}
33
34FILES_${PN} += "${libexecdir}/oci/hooks.d/"
35