Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 1 | SUMMARY = "This is the io_uring library, liburing." |
| 2 | DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \ |
| 3 | instances, and also a simplified interface for applications that don't need \ |
| 4 | (or want) to deal with the full kernel side implementation." |
| 5 | HOMEPAGE = "https://github.com/axboe/liburing" |
| 6 | BUGTRACKER = "https://github.com/axboe/liburing/issues" |
| 7 | SECTION = "libs" |
| 8 | |
| 9 | LICENSE = "LGPLv2.1 | MIT" |
| 10 | LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=d51b5805e2a675685e6a66ca50904cf9" |
| 11 | |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 12 | SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \ |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 13 | file://0001-examples-ucontext-cp.c-Do-not-use-SIGSTKSZ.patch \ |
| 14 | file://0001-tests-fix-portability-issue-when-using-__NR_mmap-sys.patch \ |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 15 | " |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 16 | SRC_URI_append_libc-musl_riscv64 = " file://0001-do-not-build-examples.patch " |
| 17 | SRC_URI_append_libc-musl_riscv32 = " file://0001-do-not-build-examples.patch " |
| 18 | |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 19 | SRCREV = "b013dfd5a5f65116373d5e0f0bdfb73db9d8816e" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | DEPENDS_append_libc-musl = " libucontext" |
| 23 | XCFLAGS = "-pthread" |
| 24 | XCFLAGS_append_libc-musl = " -lucontext" |
| 25 | |
| 26 | EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'" |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 27 | do_configure() { |
| 28 | ${S}/configure --prefix=${prefix} |
| 29 | } |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 30 | do_install () { |
| 31 | oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir} |
| 32 | } |