Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Wireless daemon for Linux" |
| 2 | LICENSE = "LGPL-2.1" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09" |
| 4 | |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 5 | inherit autotools pkgconfig systemd python3native |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 6 | |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 7 | DEPENDS = "ell readline dbus python3-docutils-native" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | |
Brad Bishop | 2f97392 | 2019-11-11 07:58:48 -0500 | [diff] [blame] | 9 | SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \ |
| 10 | file://0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch \ |
| 11 | " |
| 12 | SRCREV = "971e1d2038a203ad43bd2278a811a9e5ec8d52db" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 16 | PACKAGECONFIG[wired] = "--enable-wired,--disable-wired" |
| 17 | PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono" |
| 18 | PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd" |
| 19 | |
| 20 | EXTRA_OECONF += "--enable-external-ell" |
| 21 | |
| 22 | do_configure_prepend () { |
| 23 | mkdir -p ${S}/build-aux |
| 24 | } |
| 25 | |
| 26 | do_install_append() { |
| 27 | mkdir --parents ${D}${docdir}/${BPN} |
| 28 | install -m644 ${S}/doc/*.txt ${D}${docdir}/${BPN} |
| 29 | } |
| 30 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 31 | FILES_${PN} += "${datadir}/dbus-1 ${nonarch_libdir}/modules-load.d ${systemd_unitdir}/network/" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 32 | |
| 33 | SYSTEMD_SERVICE_${PN} = "iwd.service ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)}" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 34 | |
| 35 | RRECOMMENDS_${PN} = "\ |
| 36 | kernel-module-pkcs7-message \ |
| 37 | kernel-module-pkcs8-key-parser \ |
| 38 | kernel-module-x509-key-parser \ |
| 39 | " |