blob: 326a4abfbe6deb020c2b16b89a36f8cad8f3a1f4 [file] [log] [blame]
Brad Bishop6a62e0e2019-10-21 08:11:42 -04001SUMMARY = "fifo maps for c++"
2HOMEPAGE = "https://github.com/nlohmann/fifo_map"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=b67209a1e36b682a8226de19d265b1e0"
6
7SRC_URI = "git://github.com/nlohmann/fifo_map.git"
8
9PV = "1.0.0+git${SRCPV}"
10
11SRCREV = "0dfbf5dacbb15a32c43f912a7e66a54aae39d0f9"
12
13S = "${WORKDIR}/git"
14
15# nlohmann-fifo is a header only C++ library, so the main package will be empty.
16
17RDEPENDS_${PN}-dev = ""
18
19BBCLASSEXTEND = "native nativesdk"
20
21do_install() {
22 install -d ${D}${includedir}
23 install -m 0644 ${S}/src/fifo_map.hpp ${D}${includedir}
24}