Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | DESCRIPTION = "A high performance, open source, general-purpose RPC framework. \ |
| 2 | Provides gRPC libraries for multiple languages written on top of shared C core library \ |
| 3 | (C++, Node.js, Python, Ruby, Objective-C, PHP, C#)" |
| 4 | HOMEPAGE = "https://github.com/grpc/grpc" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=6e4cf218112648d22420a84281b68b88" |
| 8 | |
| 9 | DEPENDS = "c-ares protobuf protobuf-native protobuf-c protobuf-c-native openssl libnsl2 abseil-cpp re2" |
| 10 | DEPENDS:append:class-target = " googletest grpc-native " |
| 11 | DEPENDS:append:class-nativesdk = " grpc-native " |
| 12 | |
| 13 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 14 | |
| 15 | RDEPENDS:${PN}-compiler = "${PN}" |
| 16 | RDEPENDS:${PN}-dev:append:class-native = " ${PN}-compiler" |
| 17 | # Configuration above allows to cross-compile gRPC applications |
| 18 | # In order to compile applications on the target, use the dependency below |
| 19 | # Both dependencies are mutually exclusive |
| 20 | # RDEPENDS:${PN}-dev += "${PN}-compiler" |
| 21 | |
| 22 | S = "${WORKDIR}/git" |
Patrick Williams | 5877637 | 2022-04-13 09:07:35 -0500 | [diff] [blame] | 23 | SRCREV_grpc = "b39ffcc425ea990a537f98ec6fe6a1dcb90470d7" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 24 | BRANCH = "v1.45.x" |
| 25 | SRC_URI = "git://github.com/grpc/grpc.git;protocol=https;name=grpc;branch=${BRANCH} \ |
| 26 | file://0001-Revert-Changed-GRPCPP_ABSEIL_SYNC-to-GPR_ABSEIL_SYNC.patch \ |
Patrick Williams | 5877637 | 2022-04-13 09:07:35 -0500 | [diff] [blame] | 27 | file://0001-cmake-add-separate-export-for-plugin-targets.patch \ |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 28 | file://0001-cmake-Link-with-libatomic-on-rv32-rv64.patch \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 29 | " |
| 30 | # Fixes build with older compilers 4.8 especially on ubuntu 14.04 |
| 31 | CXXFLAGS:append:class-native = " -Wl,--no-as-needed" |
| 32 | |
| 33 | inherit cmake pkgconfig |
| 34 | |
| 35 | EXTRA_OECMAKE = " \ |
| 36 | -DgRPC_CARES_PROVIDER=package \ |
| 37 | -DgRPC_ZLIB_PROVIDER=package \ |
| 38 | -DgRPC_SSL_PROVIDER=package \ |
| 39 | -DgRPC_PROTOBUF_PROVIDER=package \ |
| 40 | -DgRPC_ABSL_PROVIDER=package \ |
| 41 | -DgRPC_RE2_PROVIDER=package \ |
| 42 | -DgRPC_INSTALL=ON \ |
| 43 | -DCMAKE_CROSSCOMPILING=ON \ |
| 44 | -DgRPC_INSTALL_LIBDIR=${baselib} \ |
| 45 | -DgRPC_INSTALL_CMAKEDIR=${baselib}/cmake/${BPN} \ |
| 46 | " |
| 47 | |
| 48 | PACKAGECONFIG ??= "cpp shared" |
| 49 | PACKAGECONFIG[cpp] = "-DgRPC_BUILD_GRPC_CPP_PLUGIN=ON,-DgRPC_BUILD_GRPC_CPP_PLUGIN=OFF" |
| 50 | PACKAGECONFIG[csharp] = "-DgRPC_BUILD_GRPC_CSHARP_PLUGIN=ON,-DgRPC_BUILD_GRPC_CSHARP_PLUGIN=OFF" |
| 51 | PACKAGECONFIG[node] = "-DgRPC_BUILD_GRPC_NODE_PLUGIN=ON,-DgRPC_BUILD_GRPC_NODE_PLUGIN=OFF" |
| 52 | PACKAGECONFIG[objective-c] = "-DgRPC_BUILD_GRPC_OBJECTIVE_C_PLUGIN=ON,-DgRPC_BUILD_GRPC_OBJECTIVE_C_PLUGIN=OFF" |
| 53 | PACKAGECONFIG[php] = "-DgRPC_BUILD_GRPC_PHP_PLUGIN=ON,-DgRPC_BUILD_GRPC_PHP_PLUGIN=OFF" |
| 54 | PACKAGECONFIG[python] = "-DgRPC_BUILD_GRPC_PYTHON_PLUGIN=ON,-DgRPC_BUILD_GRPC_PYTHON_PLUGIN=OFF" |
| 55 | PACKAGECONFIG[ruby] = "-DgRPC_BUILD_GRPC_RUBY_PLUGIN=ON,-DgRPC_BUILD_GRPC_RUBY_PLUGIN=OFF" |
| 56 | PACKAGECONFIG[protobuf-lite] = "-DgRPC_USE_PROTO_LITE=ON,-DgRPC_USE_PROTO_LITE=OFF,protobuf-lite" |
| 57 | PACKAGECONFIG[shared] = "-DBUILD_SHARED_LIBS=ON,-DBUILD_SHARED_LIBS=OFF,," |
| 58 | |
| 59 | do_configure:prepend() { |
| 60 | sed -i -e "s#lib/pkgconfig/#${baselib}/pkgconfig/#g" ${S}/CMakeLists.txt |
| 61 | } |
| 62 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 63 | BBCLASSEXTEND = "native nativesdk" |
| 64 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 65 | FILES:${PN}-compiler += " \ |
| 66 | ${bindir} \ |
| 67 | ${libdir}/libgrpc_plugin_support${SOLIBS} \ |
| 68 | " |