Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "General-purpose x86 assembler" |
| 2 | SECTION = "devel" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe" |
| 5 | |
| 6 | SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 \ |
| 7 | file://0001-asmlib-Drop-pure-function-attribute-from-seg_init.patch \ |
Brad Bishop | 220d553 | 2018-08-14 00:59:39 +0100 | [diff] [blame] | 8 | file://0001-assemble-Check-global-line-limit.patch \ |
| 9 | file://0001-fix-CVE-2018-8882.patch \ |
| 10 | file://0001-Verify-that-we-are-not-reading-past-end-of-a-buffer.patch \ |
Brad Bishop | 004d499 | 2018-10-02 23:54:45 +0200 | [diff] [blame] | 11 | file://0001-eval-Eliminate-division-by-zero.patch \ |
Brad Bishop | 6f8dcde | 2018-10-16 10:47:12 +0800 | [diff] [blame] | 12 | file://0001-preproc-parse_size-Check-for-string-provided.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 13 | " |
| 14 | |
| 15 | SRC_URI[md5sum] = "0c581d482f39d5111879ca9601938f74" |
| 16 | SRC_URI[sha256sum] = "63ec86477ad3f0f6292325fd89e1d93aea2e2fd490070863f17d48f7cd387011" |
| 17 | |
| 18 | inherit autotools-brokensep |
| 19 | |
| 20 | do_configure_prepend () { |
| 21 | if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then |
| 22 | mv ${S}/aclocal.m4 ${S}/acinclude.m4 |
| 23 | fi |
| 24 | } |
| 25 | |
| 26 | do_install() { |
| 27 | install -d ${D}${bindir} |
| 28 | install -d ${D}${mandir}/man1 |
| 29 | |
| 30 | oe_runmake 'INSTALLROOT=${D}' install |
| 31 | } |
| 32 | |
| 33 | BBCLASSEXTEND = "native" |
| 34 | |
| 35 | DEPENDS = "groff-native" |