Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "libblockdev is a C library supporting GObject introspection for manipulation of \ |
| 2 | block devices. It has a plugin-based architecture where each technology (like \ |
| 3 | LVM, Btrfs, MD RAID, Swap,...) is implemented in a separate plugin, possibly \ |
| 4 | with multiple implementations (e.g. using LVM CLI or the new LVM DBus API)." |
| 5 | HOMEPAGE = "http://rhinstaller.github.io/libblockdev/" |
| 6 | LICENSE = "LGPLv2+" |
| 7 | SECTION = "devel/lib" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c" |
| 10 | |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 11 | inherit autotools gobject-introspection |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 13 | SRC_URI = "git://github.com/storaged-project/libblockdev;branch=2.x-branch" |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 14 | SRCREV = "c50869272b54bf4b4bc3825e8c3332a54678b43f" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | S = "${WORKDIR}/git" |
| 16 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 17 | FILES_${PN} += "${libdir}/python2.7/dist-packages ${libdir}/python3.*/site-packages" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | |
| 19 | PACKAGECONFIG ??= "python3 lvm dm kmod parted fs escrow btrfs crypto mdraid kbd mpath nvdimm" |
| 20 | PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3" |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 21 | PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2" |
| 23 | PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus, --without-lvm_dbus, multipath-tools, lvm2" |
| 24 | PACKAGECONFIG[dm] = "--with-dm, --without-dm, multipath-tools, lvm2" |
| 25 | PACKAGECONFIG[dmraid] = "--with-dmraid, --without-dmraid" |
| 26 | PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd, kmod" |
| 27 | PACKAGECONFIG[parted] = "--with-part, --without-part, parted" |
| 28 | PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux" |
| 29 | PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native" |
| 30 | PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm, ndctl util-linux" |
| 31 | PACKAGECONFIG[vdo] = "--with-vdo, --without-vdo" |
| 32 | PACKAGECONFIG[escrow] = "--with-escrow, --without-escrow, nss volume-key" |
| 33 | PACKAGECONFIG[btrfs] = "--with-btrfs,--without-btrfs,libbytesize btrfs-tools" |
| 34 | PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,cryptsetup nss volume-key" |
| 35 | PACKAGECONFIG[mdraid] = "--with-mdraid,--without-mdraid,libbytesize" |
| 36 | PACKAGECONFIG[kbd] = "--with-kbd,--without-kbd,libbytesize" |
| 37 | PACKAGECONFIG[mpath] = "--with-mpath,--without-mpath, multipath-tools, lvm2" |
| 38 | |
| 39 | export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs" |