Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | require libgpiod.inc |
| 2 | |
| 3 | DEPENDS += "autoconf-archive-native" |
| 4 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 5 | SRC_URI[md5sum] = "585b4bb431f99c4ba9b3ee58b9d494c1" |
| 6 | SRC_URI[sha256sum] = "21ae8fd1f8dafc2eb2ba50e652390cf533d21351419a7426255895cb52e21b1c" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 8 | # enable cxx bindings |
| 9 | PACKAGECONFIG ?= "cxx" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 10 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx" |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame] | 12 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | |
| 14 | PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3" |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 15 | |
| 16 | inherit python3native |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 17 | |
| 18 | PACKAGES =+ "${PN}-python" |
| 19 | FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" |
| 20 | RRECOMMENDS_PYTHON = "${@bb.utils.contains('PACKAGECONFIG', 'python3', '${PN}-python', '',d)}" |
| 21 | RRECOMMENDS_${PN}-python += "${RRECOMMENDS_PYTHON}" |