blob: 572030c53b055332a8e71ccca952679ef66b4a5f [file] [log] [blame]
Adriana Kobylak6161f452015-10-19 14:15:04 -04001SUMMARY = "Temp placeholder for skeleton function"
2DESCRIPTION = "Temp placeholder for skeleton repository"
3HOMEPAGE = "http://github.com/openbmc/skeleton"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
Brad Bishopc88c37c2015-10-21 20:24:23 -04008inherit obmc-phosphor-chassis-mgmt
9inherit obmc-phosphor-event-mgmt
10inherit obmc-phosphor-fan-mgmt
11inherit obmc-phosphor-flash-mgmt
12inherit obmc-phosphor-policy-mgmt
13inherit obmc-phosphor-sensor-mgmt
14inherit obmc-phosphor-system-mgmt
Adriana Kobylak6161f452015-10-19 14:15:04 -040015
16DEPENDS += "glib-2.0"
Brad Bishop51c0f7d2015-10-19 14:22:57 -040017RDEPENDS_${PN} += "python-subprocess python-tftpy"
Adriana Kobylak6161f452015-10-19 14:15:04 -040018SRC_URI += "git://github.com/openbmc/skeleton"
Adriana Kobylak6161f452015-10-19 14:15:04 -040019
Adriana Kobylak75b8b382015-10-29 11:14:29 -050020SRCREV = "597d49e68e8bf0ddedb2e01cbd3fb500ee1c22e3"
Adriana Kobylak6161f452015-10-19 14:15:04 -040021
Brad Bishop59ca1fd2015-10-28 08:13:43 -050022S = "${WORKDIR}"
Adriana Kobylak6161f452015-10-19 14:15:04 -040023
24do_compile() {
Adriana Kobylak75b8b382015-10-29 11:14:29 -050025 oe_runmake -C git
Adriana Kobylak6161f452015-10-19 14:15:04 -040026}
27
28do_install() {
Brad Bishop59ca1fd2015-10-28 08:13:43 -050029 source=${S}/git
30
Adriana Kobylak6161f452015-10-19 14:15:04 -040031 install -d ${D}/${sbindir} ${D}${libdir}
Adriana Kobylak75b8b382015-10-29 11:14:29 -050032 for i in ${source}/bin/*; do
Adriana Kobylak6161f452015-10-19 14:15:04 -040033 install $i ${D}/${sbindir}
34 done
Adriana Kobylak75b8b382015-10-29 11:14:29 -050035 for i in ${source}/lib/*; do
36 install $i ${D}/${libdir}
37 done
Adriana Kobylak6161f452015-10-19 14:15:04 -040038}