blob: 2a67b77e0848da1ff2b26f34cd24771e66106fba [file] [log] [blame]
Brad Bishop5f9be072016-06-27 14:53:52 -04001SUMMARY = "org.openbmc.control.Host implementation for OpenPOWER"
2DESCRIPTION = "A host control implementation suitable for OpenPOWER systems."
Ed Tanous9936f862022-09-19 09:13:20 -07003PROVIDES += "virtual/obmc-host-ctl"
Patrick Venturec233b002018-10-09 20:20:36 -07004PV = "1.0+git${SRCPV}"
Ed Tanous9936f862022-09-19 09:13:20 -07005PR = "r1"
6
7SKELETON_DIR = "op-hostctl"
8SYSTEMD_SERVICE:${PN} = " \
9 op-start-host@.service \
10 "
11START_TMPL = "op-start-host@.service"
12START_TGTFMT = "obmc-host-startmin@{1}.target"
13START_INSTFMT = "op-start-host@{0}.service"
14START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}"
15SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"
Patrick Williamsb81c1fb2024-03-08 21:44:55 -060016SYSTEMD_LINK[vardeps] += "OBMC_HOST_INSTANCES OBMC_CHASSIS_INSTANCES"
Brad Bishop5f9be072016-06-27 14:53:52 -040017
18inherit skeleton-gdbus
Brad Bishop1d525fa2016-08-17 20:27:37 -040019inherit obmc-phosphor-dbus-service
Brad Bishop92673622018-01-26 21:30:17 -050020inherit pkgconfig
Brad Bishop5f9be072016-06-27 14:53:52 -040021
Patrick Williams12fc9392021-08-06 09:16:53 -050022RPROVIDES:${PN} += "virtual-obmc-host-ctl"
Sergey Solominaac4adf2016-11-28 15:03:24 -060023
Andrew Geisslerb5ad4102023-06-28 15:32:06 -050024DBUS_SERVICE:${PN} += "org.openbmc.control.Host@.service"
25OBMC_CONTROL_INST = "org.openbmc.control.Host@{0}.service"
26OBMC_CONTROL_SVC = "org.openbmc.control.Host@.service"
27OBMC_CONTROL_FMT = "../${OBMC_CONTROL_SVC}:multi-user.target.wants/${OBMC_CONTROL_INST}"
28SYSTEMD_LINK:${PN} += "${@compose_list(d, 'OBMC_CONTROL_FMT', 'OBMC_HOST_INSTANCES')}"