blob: 291a83aaad8605c7079b765210760df614a12ba1 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Kernel selftest for Linux"
2DESCRIPTION = "Kernel selftest for Linux"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-2.0-only"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004
5LIC_FILES_CHKSUM = "file://../COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
6
7DEPENDS = "rsync-native llvm-native"
8
9# for musl libc
Patrick Williams213cb262021-08-07 19:21:33 -050010SRC_URI:append:libc-musl = "\
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011 file://userfaultfd.patch \
12 "
13SRC_URI += "file://run-ptest \
14 file://COPYING \
15 "
16
17# now we just test bpf and vm
18# we will append other kernel selftest in the future
19# bpf was added in 4.10 with: https://github.com/torvalds/linux/commit/5aa5bd14c5f8660c64ceedf14a549781be47e53d
20# if you have older kernel than that you need to remove it from PACKAGECONFIG
Patrick Williams213cb262021-08-07 19:21:33 -050021PACKAGECONFIG ??= "firmware"
Andrew Geissler20137392023-10-12 04:59:14 -060022# bpf needs working clang compiler anyway
23PACKAGECONFIG:append:toolchain-clang:x86-64 = " bpf"
Patrick Williams213cb262021-08-07 19:21:33 -050024PACKAGECONFIG:remove:x86 = "bpf"
25PACKAGECONFIG:remove:arm = "bpf vm"
Andrew Geissler82c905d2020-04-13 13:39:40 -050026# host ptrace.h is used to compile BPF target but mips ptrace.h is needed
27# progs/loop1.c:21:9: error: incomplete definition of type 'struct user_pt_regs'
28# m = PT_REGS_RC(ctx);
Andrew Geisslerd688a012020-09-18 13:36:00 -050029# vm tests need libhugetlbfs starting 5.8+ (https://lkml.org/lkml/2020/4/22/1654)
Patrick Williams213cb262021-08-07 19:21:33 -050030PACKAGECONFIG:remove:qemumips = "bpf vm"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031
Andrew Geissler4b7c1152020-11-30 19:55:29 -060032# riscv does not support libhugetlbfs yet
Andrew Geissler20137392023-10-12 04:59:14 -060033PACKAGECONFIG:remove:riscv64 = "bpf vm"
34PACKAGECONFIG:remove:riscv32 = "bpf vm"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060035
Andrew Geissler20137392023-10-12 04:59:14 -060036PACKAGECONFIG[bpf] = ",,elfutils elfutils-native libcap libcap-ng rsync-native python3-docutils-native,"
Andrew Geissler82c905d2020-04-13 13:39:40 -050037PACKAGECONFIG[firmware] = ",,libcap, bash"
Andrew Geisslerd688a012020-09-18 13:36:00 -050038PACKAGECONFIG[vm] = ",,libcap libhugetlbfs,libgcc bash"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080039
40do_patch[depends] += "virtual/kernel:do_shared_workdir"
Andrew Geissler20137392023-10-12 04:59:14 -060041do_compile[depends] += "virtual/kernel:do_install"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080042
Andrew Geissler20137392023-10-12 04:59:14 -060043inherit linux-kernel-base module-base kernel-arch ptest siteinfo
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080044
45S = "${WORKDIR}/${BP}"
46
Andrew Geissler20137392023-10-12 04:59:14 -060047DEBUG_PREFIX_MAP:remove = "-fcanon-prefix-map"
48
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080049TEST_LIST = "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050050 ${@bb.utils.filter('PACKAGECONFIG', 'bpf firmware vm', d)} \
Brad Bishope42b3e32020-01-15 22:08:42 -050051 rtc \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080052"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080053EXTRA_OEMAKE = '\
54 CROSS_COMPILE=${TARGET_PREFIX} \
55 ARCH=${ARCH} \
56 CC="${CC}" \
57 AR="${AR}" \
58 LD="${LD}" \
Andrew Geissler20137392023-10-12 04:59:14 -060059 CLANG="clang -fno-stack-protector -target ${TARGET_ARCH} ${TOOLCHAIN_OPTIONS} -isystem ${S} -D__WORDSIZE=\'64\' -Wno-error=unused-command-line-argument" \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080060 DESTDIR="${D}" \
Andrew Geissler20137392023-10-12 04:59:14 -060061 V=1 \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080062'
Andrew Geissler20137392023-10-12 04:59:14 -060063EXTRA_OEMAKE:append:toolchain-clang = "\
64 LLVM=1 CONFIG_CC_IS_GCC= CONFIG_CC_IS_CLANG=y CONFIG_CC_IMPLICIT_FALLTHROUGH= \
65 HOSTCC="clang -unwindlib=libgcc -rtlib=libgcc -stdlib=libstdc++ ${BUILD_CFLAGS} ${BUILD_LDFLAGS} -Wno-error=unused-command-line-argument" \
66 HOSTLD="clang ${BUILD_LDFLAGS} -unwindlib=libgcc -rtlib=libgcc -stdlib=libstdc++" \
67"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080068
69KERNEL_SELFTEST_SRC ?= "Makefile \
70 include \
Andrew Geisslerd688a012020-09-18 13:36:00 -050071 kernel \
72 lib \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080073 tools \
74 scripts \
75 arch \
76 LICENSES \
77"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080078do_compile() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050079 if [ ${@bb.utils.contains('PACKAGECONFIG', 'bpf', 'True', 'False', d)} = 'True' ]; then
Brad Bishop0f291cc2019-09-01 15:16:57 -040080 if [ ${@bb.utils.contains('DEPENDS', 'clang-native', 'True', 'False', d)} = 'False' ]; then
81 bbwarn "clang >= 6.0 with bpf support is needed with kernel 4.18+ so
82either install it and add it to HOSTTOOLS, or add clang-native from meta-clang to dependency"
83 fi
Andrew Geissler82c905d2020-04-13 13:39:40 -050084 fi
Andrew Geissler20137392023-10-12 04:59:14 -060085 mkdir -p ${S}/include/config ${S}/bits
86 install -Dm 0644 ${STAGING_KERNEL_BUILDDIR}/.config ${S}/include/config/auto.conf
87 if [ "${SITEINFO_BITS}" != "32" ]; then
88 for f in long-double endianness floatn struct_rwlock; do
89 cp ${RECIPE_SYSROOT}${includedir}/bits/$f-64.h ${S}/bits/$f-32.h
90 done
91 fi
Andrew Geissler220dafd2023-10-04 10:18:08 -050092 oe_runmake -C ${S} headers
Andrew Geissler20137392023-10-12 04:59:14 -060093 sed -i -e 's|^all: docs|all:|' ${S}/tools/testing/selftests/bpf/Makefile
94 sed -i -e '/mrecord-mcount/d' ${S}/Makefile
95 sed -i -e '/Wno-alloc-size-larger-than/d' ${S}/Makefile
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080096 for i in ${TEST_LIST}
97 do
98 oe_runmake -C ${S}/tools/testing/selftests/${i}
99 done
100}
101
102do_install() {
103 for i in ${TEST_LIST}
104 do
105 oe_runmake -C ${S}/tools/testing/selftests/${i} INSTALL_PATH=${D}/usr/kernel-selftest/${i} install
Andrew Geisslerd5838332022-05-27 11:33:10 -0500106 # Install kselftest-list.txt that required by kselftest runner.
107 oe_runmake -s --no-print-directory COLLECTION=${i} -C ${S}/tools/testing/selftests/${i} emit_tests \
108 >> ${D}/usr/kernel-selftest/kselftest-list.txt
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800109 done
Andrew Geisslerd5838332022-05-27 11:33:10 -0500110 # Install kselftest runner.
111 install -m 0755 ${S}/tools/testing/selftests/run_kselftest.sh ${D}/usr/kernel-selftest/
112 cp -R --no-dereference --preserve=mode,links -v ${S}/tools/testing/selftests/kselftest ${D}/usr/kernel-selftest/
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800113 if [ -e ${D}/usr/kernel-selftest/bpf/test_offload.py ]; then
114 sed -i -e '1s,#!.*python3,#! /usr/bin/env python3,' ${D}/usr/kernel-selftest/bpf/test_offload.py
115 fi
116 chown root:root -R ${D}/usr/kernel-selftest
117}
118
119do_configure() {
120 install -D -m 0644 ${WORKDIR}/COPYING ${S}/COPYING
121}
122
123do_patch[prefuncs] += "copy_kselftest_source_from_kernel remove_unrelated"
124python copy_kselftest_source_from_kernel() {
125 sources = (d.getVar("KERNEL_SELFTEST_SRC") or "").split()
126 src_dir = d.getVar("STAGING_KERNEL_DIR")
127 dest_dir = d.getVar("S")
128 bb.utils.mkdirhier(dest_dir)
129 for s in sources:
130 src = oe.path.join(src_dir, s)
131 dest = oe.path.join(dest_dir, s)
132 if os.path.isdir(src):
133 oe.path.copytree(src, dest)
134 else:
135 bb.utils.copyfile(src, dest)
136}
137
138remove_unrelated() {
139 if ${@bb.utils.contains('PACKAGECONFIG','bpf','true','false',d)} ; then
140 test -f ${S}/tools/testing/selftests/bpf/Makefile && \
141 sed -i -e 's/test_pkt_access.*$/\\/' \
142 -e 's/test_pkt_md_access.*$/\\/' \
143 -e 's/sockmap_verdict_prog.*$/\\/' \
144 ${S}/tools/testing/selftests/bpf/Makefile || \
145 bberror "Your kernel is probably older than 4.10 and doesn't have tools/testing/selftests/bpf/Makefile file from https://github.com/torvalds/linux/commit/5aa5bd14c5f8660c64ceedf14a549781be47e53d, disable bpf PACKAGECONFIG"
146 fi
147}
148
149PACKAGE_ARCH = "${MACHINE_ARCH}"
150
151INHIBIT_PACKAGE_DEBUG_SPLIT="1"
Patrick Williams213cb262021-08-07 19:21:33 -0500152FILES:${PN} += "/usr/kernel-selftest"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800153
Andrew Geissler20137392023-10-12 04:59:14 -0600154RDEPENDS:${PN} += "python3 perl perl-module-io-handle"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800155# tools/testing/selftests/vm/Makefile doesn't respect LDFLAGS and tools/testing/selftests/Makefile explicitly overrides to empty
Andrew Geissler20137392023-10-12 04:59:14 -0600156INSANE_SKIP:${PN} += "ldflags libdir"
Brad Bishop26bdd442019-08-16 17:08:17 -0400157
Brad Bishop0f291cc2019-09-01 15:16:57 -0400158SECURITY_CFLAGS = ""
Patrick Williams213cb262021-08-07 19:21:33 -0500159COMPATIBLE_HOST:libc-musl = 'null'
Brad Bishop5f78ea12019-09-10 07:20:03 -0400160
Brad Bishopdec060e2019-09-23 08:01:31 -0400161# It has native clang/llvm dependency, poky distro is reluctant to include them as deps
162# this helps with world builds on AB
163EXCLUDE_FROM_WORLD = "1"