blob: 22868d8df06bf5594877a49865c653211ed52d25 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python wrapper around rapidjson"
2HOMEPAGE = "https://github.com/python-rapidjson/python-rapidjson"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4daf3929156304df67003c33274a98bd"
6
Patrick Williams169d7bc2024-01-05 11:33:25 -06007SRC_URI[sha256sum] = "26806f0a658c34b48d2951d8d3f846ca9deb93a34e664ef436db632a188b6779"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06008
9# Inheriting ptest provides functionality for packaging and installing runtime tests for this recipe
Patrick Williams169d7bc2024-01-05 11:33:25 -060010inherit setuptools3 pypi ptest
11
12PYPI_PACKAGE = "python-rapidjson"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060013
14SETUPTOOLS_BUILD_ARGS += " --rj-include-dir=${RECIPE_SYSROOT}${includedir}"
15
16# run-ptest is a shell script that starts the test suite
17SRC_URI += " \
18 file://run-ptest \
19"
20
21DEPENDS += " \
22 rapidjson \
23"
24
25# Adding required python package for the ptest (pytest and pytest->automake report translation)
26RDEPENDS:${PN}-ptest += " \
Patrick Williams39653562024-03-01 08:54:02 -060027 python3-pytest \
28 python3-unittest-automake-output \
29 python3-pytz \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060030"
31
32RDEPENDS:${PN} += " \
Patrick Williams39653562024-03-01 08:54:02 -060033 python3-core \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060034"
35
36# Installing the test suite on the target
37do_install_ptest() {
38 install -d ${D}${PTEST_PATH}/tests
39 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
40}