Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 1 | SUMMARY = "Classes Without Boilerplate" |
| 2 | HOMEPAGE = "http://www.attrs.org/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5e55731824cf9205cfabeab9a0600887" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "935dc3b529c262f6cf76e50877d35a4bd3c1de194fd41f47a2b7ae8f19971f30" |
| 7 | |
| 8 | inherit pypi ptest python_hatchling |
| 9 | |
| 10 | SRC_URI += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 11 | file://0001-test_funcs-skip-test_unknown-for-pytest-8.patch \ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 12 | file://0001-conftest.py-disable-deadline.patch \ |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 13 | file://run-ptest \ |
| 14 | " |
| 15 | |
| 16 | DEPENDS += " \ |
| 17 | python3-hatch-vcs-native \ |
| 18 | python3-hatch-fancy-pypi-readme-native \ |
| 19 | " |
| 20 | |
| 21 | RDEPENDS:${PN}+= " \ |
| 22 | python3-compression \ |
| 23 | python3-ctypes \ |
| 24 | python3-crypt \ |
| 25 | " |
| 26 | |
| 27 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 28 | python3-hypothesis \ |
| 29 | python3-pytest \ |
| 30 | python3-unittest-automake-output \ |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 31 | " |
| 32 | |
| 33 | do_install_ptest() { |
| 34 | install -d ${D}${PTEST_PATH}/tests |
| 35 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 36 | install ${S}/conftest.py ${D}${PTEST_PATH}/ |
| 37 | } |
| 38 | |
| 39 | BBCLASSEXTEND = "native nativesdk" |