Alexander Filippov | 000c8ff | 2020-06-10 17:55:57 +0300 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
| 2 | |
| 3 | inherit systemd |
| 4 | |
| 5 | RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}" |
| 6 | SYSTEMD_SERVICE_${PN} = "${BPN}.service" |
| 7 | SRC_URI_append = " \ |
| 8 | file://${BPN}-set-device-id.sh \ |
| 9 | file://${BPN}.service \ |
| 10 | " |
| 11 | |
| 12 | S = "${WORKDIR}" |
| 13 | do_install_append() { |
| 14 | install -d ${D}${bindir} ${D}${systemd_system_unitdir} |
| 15 | install ${BPN}-set-device-id.sh ${D}${bindir}/ |
| 16 | install -m 0644 ${BPN}.service ${D}${systemd_system_unitdir}/ |
| 17 | } |
| 18 | |
| 19 | FILES_${PN}_append = " \ |
| 20 | ${bindir}/${BPN}-set-device-id.sh \ |
| 21 | " |